PDA

View Full Version : Crazy PS/2 Mouse



Mzee
14-09-2003, 03:03 AM
I have a very reliablle AMD K6 computer as a spare & test bench.
Just lately the PS/2 mouse causes windows to open at random. If I unplug the ps/2 mouse & use a serial mouse, everything is fine.
I have tried 3 mice. Checked the socket for shorts. Changed the driver.
Checked for conflicts [always been IRQ12 ]

The ps/2 mouse works fine in Dos with Partition Magic & Norton Ghost, but not Windows ME [ Windows has been reinstalled] It stops working as soon as Windows setup starts. Had to reinstall with a serial mouse.

Any ideas? :)

mikep
14-09-2003, 10:37 AM
Try rebooting windows into safe mode and checking your device manager. You may see a number of mouse/pionting devices in there and maybe even some double/triple ups of the same device. Remove them all (you will still have a usable mouse in safe mode) then reboot your PC with the ps/2 mouse still plugged in. When windows starts, it should find your mouse.

Have you checked for an updated display driver? The display driver and the mouse are dependent on each other for proper mousing. Without one the other will not perform its function vety well.

As a sideline, check the time and date in Windows as it reads it from your BIOS. If your time and date have changed radically, like back to 1998ish, you might find your cmos battery on your motherboard has lost its charge and will need replacing. It may not sound related, but if your cmos settings are forever resetting themselves because your battery can not hold it's charge overnight, changing your battery may help.

Fire-and-Ice
14-09-2003, 10:44 AM
It may be a good idea to scan with an anti-virus as well.