PDA

View Full Version : Mandrake root access



Nuts8
08-07-2003, 12:32 PM
Hi,

I have been following the current step by step linux guide in PC World and as a result I have PC running Mandrake Linux 9.1. One thing I am having trouble with I cant log into the computer as root, usually there is an option to log in as root but I can only log in as myself.

When I try and do some things in the system, it sais that I need root access, I thought it would just prompt me for the root password but it doesnt, it just doesnt let me do what I want to do. An example is trying to unmount the CD Rom drive by right clicking on the desktop icon and selecting unmount, apparently this requires root privelages which I cant get access to. I have tryed typing su in the konsole and entering the root password, but this has no effect.

Any thoughts would be appreciated
Thanks

Jen C
08-07-2003, 01:06 PM
Try using CTRL+ALT+Backspace to kill X (your KDE or Gnome), and then at the prompt enter root for username and then the password. Remember to switch back to your normal login when you have finished.

Jen C
08-07-2003, 01:20 PM
hmmm ... in Konsole what are you typing to unmount the CDROM? You should just need to type this:
umount /mnt/cdrom

Graham L
08-07-2003, 05:14 PM
Another problem can occur when the CD is "still in use". That's when you have a session which is "in" one of the CD directories.

I finally got Mandrake (9.)) going on one machine. I managed to have /dev/cdrom mounted four times according to mtab. It didn't want to be unmounted. :D

Apart from the fact that APC gave the install CDs names which Mandrakes application installer doesn't recognise, and pilot-link doesn't want to work (just like Windows) ... I'm reserving judgement. Like all modern distributions it wants far too much disk space. :D

To get a root session, all you have to do is Ctrl/Alt/F1 (or F2, F3, ... F6). F7 is the X-Window session, so you can get back to that from the root console session with Alt/F7.

Marshell
09-07-2003, 08:52 PM
Go to Start -> Configuration -> KDE -> System -> Login Manager.

Then under the "Users" tab, uncheck root as a hidden user.

Logout and you will be given the option of logging in as root from now on.

It's a bit of a hidden option but very useful once you've done it.

I posted the same question a couple of weeks ago, Thanks LinuxShop.co.nz for the answer