PDA

View Full Version : Dynalink RTA220 ASDL Router



Painty
07-06-2003, 12:11 PM
I have a newly purchased Dynalink RTA220 and can't transfer files either via ICQ or DC++.

The built in firewall is disabled so I don't see how I need to pinhole it.

Paradise are my ISP (though I don't think that matters as i'm pretty sure they don't block any ports)

It doesnt work even when all firewall software on my system is disabled.
I had the same issue with a Nokia M1122 (since killed by a power spike)

Suggestions?

Terry Porritt
07-06-2003, 02:26 PM
Have the same model router, and have the same problem as you. I havent found the full answers to either ICQ, NetMeeting or Microsoft Messenger for file sending/sharing etc. despite setting up virual servers with relevant port numbers, or even setting up DMZ.
The problem lies with the Network Address Translation somehow.

What does work and worked well first time with no messing around is Yahoo Messenger, both for audio/visual coms, for file transfer etc. So that is what I would recommend. The only slight disadvantage with Yahoo is that the chat window is more like one way message sending rather than the simultaneously open chat windows you get in ICQ, where you can see the typing the other end comming along.

Terry Porritt
07-06-2003, 02:35 PM
Also, I forgot to say, this router doesnt have facility for opening wide ranges of ports such as some applications like NM and ICQ require where ports are dynamically assigned with a range.
So even though the Dynalink blurb talks about supporting NetMeeting ICQ etc, it isnt fully true. Only true for very limited use of these applications.

jackyht
07-06-2003, 04:45 PM
Hi Terry and Painty

I have a older model with u, RTA 210... i also can't chat online anyway... it is because of the NAT (RTA210) and the firewall (RTA220) are blocked all those communication....

But in terms of transferring files, you can't do that too, u can do it thru Computer A and Computer B thru ur network only. However, the strange thing is, I can transfer files to people who have 56k modem which is really strange.

In order to transfer files or net-meeting, you really need to open the port for your router (that mean turning off Firewall or NAT on your router), but in this situation, it is quite dangerous as attacker starts to attack in, but i think dynalink actually give out the info how to open the port tho. I think i have post a similar message before.. hang on, i go for a search 1st and i will post the link again on the next message...

jackyht
07-06-2003, 04:49 PM
i find it.

here is the link http://www.dynalink.co.nz/support/setting_pinholes.pdf

jacky

Painty
07-06-2003, 04:57 PM
Thanks so'far guys.

jackyht : I did actually find that page on Dynalinks website. unfortunately my version of the firmware is newer (and consequently different) than the example posted.

I have requested assistance from Dynalink who I have always found to be friendly and helpful in previous dealings and will post an update.

Though please keep the ideas rolling in :)

Terry Porritt
07-06-2003, 06:30 PM
Here are some useful sites with information on the ports that need to be opened.
For NetMeeting:

http://support.microsoft.com/default.aspx?scid=kb;en-us;Q158623

http://www.homenethelp.com/help/netmeeting-router.asp


The big problem with NetMeeting is that the system has to pass through secondary UDP connections on dynamically assigned ports in the range 1024-65535. You cant do this with the Dynalink (Im happy to be corrected on this).


This site was really useful for ICQ, and at least it got Chat going:
http://www.bubbledvd.com/Router/

The SMC Barracade router is much like the Dynalink, my son in Canada has one, we opened up ports 12000-12004 and set up ICQ as it describes and we got chat to work but not much else. Then something happened after I upgraded ICQ, and calls couldnt be accepted from either direction, but they could on one of my other supposedly identicle networked computers (identicle software that is).

We tried MSN Messenger and were able to send messages to and fro but not audio/visual contact. I think XP with UPnP is required, Im running Win98SE.

That was when we tried Yahoo Messenger, and all problems vanished :) :)

Life seemed a bit simpler with dial-up and a soft firewall.
BTW, the Dynalink firewall is such a pain to set set up for all applications that want to access the internet. I use Kerio soft firewall in conjunction with the built in protection of NAT, it's so much easier to use.

(Why does F1 make bold type after putting in full URLs, but not when using the format [url= etc] ?:| )

sloanie
07-06-2003, 07:25 PM
my friend has this router, he cannot download files from some kazaa users. its all to do with something called PCMP (those letters, wouldnt know which order). They suck.........end of story


Just get a DSE router......pretty cheap and they actually work!

Big John
07-06-2003, 07:57 PM
You need to set you computer to have a static IP address and not use the DHCP. Once that is done you can use the DMZ to ensure that the RTA220 will forward all data to the IP you tell it to.

An example.
The router has an IP of 192.168.1.1
Set your computer to have an IP of 192.168.0.2
Set the DMZ in the router to 192.168.0.2.

I send files thru Kazaa no problems with having to use the the DMZ. Transferring with ICQ does involve the DMZ but once set it does work as I have tried it and used it many times.

Terry Porritt
07-06-2003, 08:15 PM
Yes big John, I have that set up of fixed IP and tried the DMZ for ICQ, but still we couldnt get ICQ file sharing or NM audio/visual to work, in either direction.

hoopzta
09-06-2003, 04:41 PM
You guys are completley wrong. I have icq and msn messanger working fine.
Also it does do port ranges if you create a new filtering rule when the firewall is set to advanced. You dont just have to set it up in the virtual server but saying that netmeeting doesnt work is crap it even fully functioned on the rta210.

Big John
09-06-2003, 04:53 PM
> You guys are completley wrong. I have icq and msn
> messanger working fine.
> Also it does do port ranges if you create a new
> filtering rule when the firewall is set to advanced.
> You dont just have to set it up in the virtual server
> but saying that netmeeting doesnt work is crap it
> even fully functioned on the rta210.

Sure the RTA210 works fine but it wont transfer files properly. Try them both ways. You need to set pinholes or use the DMZ on the RTA220.
Just chatting and e-mail, etc works fine but try file or video and she no work without extra.
Of course with the RTA220 you could use UPNP but it is buggy on the RTA220. Waiting for a firmware update.

hoopzta
09-06-2003, 05:05 PM
The update is available on request from support@dynalink.co.nz I asked the other day and they are about to put it on the website soon.
I havn't had any problem with file transfer so don't know whay you havn't.

Terry Porritt
09-06-2003, 06:42 PM
That's interesting, hooptza. If you could let us know what rules you have set up for MSN, ICQ, NetMeeting (if that doesnt take up too much space), then that would be very valuable information.
Cheers

Big John
09-06-2003, 10:17 PM
> The update is available on request from
> support@dynalink.co.nz I asked the other day and they
> are about to put it on the website soon.
> I havn't had any problem with file transfer so don't
> know whay you havn't.

That is the Australian version which NZ agent won't say yes it works. They say try at your own risk.

I just use my Vigor 2600 which has UPNP working and also has no problems with the Tracert program whicg the RTA220 does. It will only show the first and last hop for names. All others disappear.

hoopzta
10-06-2003, 12:20 PM
The traceroute problem is solved in the rta220 new firmware which is due on the website this week.

Netmeeting and icq both have predefined ports setup through the virtual server. All you need to do is have the ip adress in there and click apply.

As for msn you need to have ports 1863,21, 6100-6109 and that should work fine.

Kame
10-06-2003, 12:38 PM
Ports I have set up for MSN and have it working with File Transfer/Video are:

6891 TCP File Transfer Port
6892 TCP File Transfer Port (if you do more than sending two files at once then ports 6893-6901 TCP)

5190 UDP (forgot what this port is for although ICQ uses it except I only set up MSN pinholes on the router :/ )

1863 TCP/UDP
5060 TCP/UDP
1503 TCP/UDP
3389 TCP/UDP

These are all the working ports I know of to get MSN working.

I've posted a thread asking about the ports required and had two good links that provided the answer.

Terry Porritt
10-06-2003, 02:22 PM
The problems I was getting may be associated with Win98, I read that for MSN audio/video, one needs XP with UPnP. I had those ports set up as Virtual Servers that you list Kame, and though the messaging works the audio/visual doesnt.

I havent used the Dynalink firewall, just set up Virtual Servers with the port numbers found from either MS, ICQ, or other sites etc. I had ICQ going more or less ok at one stage, using the advice given in a link I posted higher up, but then when I upgraded to a later build things turned to custard, couldnt even accept a chat request . Re-installing the older version didnt help either. Weird.

However Yahoo messenger works ok in all aspects.

So hooptza, if a range of ports like from 1024-65535 need to be opened for NM, then this has to be done in the Firewall as well as using the Dynalink predefind ports in the Virtual Server set up??

Kame
10-06-2003, 03:06 PM
I've spent ages determining why it works and doesn't work, that I may have stumbled across the problem without knowing it, I use to test it with a friend of mine and got him to check what was happening. I realised that NAT wasn't doing it's job correctly and kept sending my LAN IP not my actual IP Address.

I also tried running scripts on the router itself to setup more ports than the amount you get by using the browser (this was via telnet) although doing this you should not use the browser to view what was done as I don't know what results you can get from that.

Port 21 shouldn't be required for MSN.

Terry Porritt
10-06-2003, 03:35 PM
This site (http://www.compusmart.ab.ca/mikes/lvideo7.html#linksys) indicates that XP and UPnP is needed for MSN audio and video, also note the port range 5004-65535 that needs to be dynamically opened.

As I mentioned before it was so much easier with dial-up and a soft firewall, just said 'yes' when the firewall asked if it could send out or receive data for a program :)

Kame
10-06-2003, 05:18 PM
Have you set those port ranges on your firewall?

Terry Porritt
10-06-2003, 05:50 PM
I gave up on the Dynalink firewall Kame, because when I first had the router, and set the firewall to Low setting, it wouldnt even let me listen to all my favourite streaming audio programs and music files on a host of sites. It wouldnt let me connect to other places either, which I've now forgotten what they were:).

It would have been too much of a pain to try to set it for everything I normally do. Now thats maybe the reason I couldnt get NM to work, but I dont know. There is only one port number predefined in the Virtual Server for NM, 1720, whereas the MS site quoted nearer the top of this thread lists 5 ports plus the enormous range of dynamically assigned ones for UPD.

This afternoon I started the firewall on the minimum low security setting, just to check again, and sure enough Live365 stations stopped working. I just cant be bothered with it, especially as Yahoo Messenger, with audio/video/file sending etc works a treat with none of the problems that NM and ICQ gave me.

In fact I have now uninstalled NM and ICQ, I said Toyota to them :D

hoopzta
11-06-2003, 03:17 PM
Yes thats correct when you need a port range it must be done through the firewall

Terry Porritt
11-06-2003, 05:55 PM
I think I'm gradually beginning to understand the Dynalink firewall ( a little anyway), but it is difficult compared to a soft firewall. I understand that for example. stations on Live365 each use different port numbers (if they can be found out), so for each station a filter rule would need to be set up. That is really too much. Thanks anyway hoopzta.