PDA

View Full Version : Red Hat 8 - installing kernel update



Jen C
05-06-2003, 07:13 PM
Hi all

I have recently installed Red Hat 8. I used the up2date program to check for updates (no suprise here :)) and decided to download a kernel update. The Red Hat Update Agent downloaded the file and then the installation process started until it reach 100% complete where it seemed to hang. I waited for about 10 minutes for the "Forward" button to become active, but it never did. I gave up and simply closed the program down. I rebooted the machine and noted that the old kernel version was loading.

The Red Hat Network Alert Notification tool now gives me this message under critical information:

Your system is currently running kernel-2.4.18-14, but the newest installed kernel is kernel-2.4.20-18.8. It is recommended that you reboot at the first opportunity to test this new kernel.

I have rebooted many times now, and when using the up2date program the new kernel is not listed as available to download again. I have downloaded other updates with no problems.

I am either doing something embarrassingly wrong or did the apparent "hang" during installation cause this. Do I need to do something else to get the new kernel to load?

Any advice would be appreciated - but please keep it simple as I am still in the beginners class with linux. :)

Cheers
Jen

Chilling_Silently
05-06-2003, 11:17 PM
I think you have to edit the grub.conf file in /etc/ and specify the new kernel?!

Graham L
06-06-2003, 01:49 PM
First, try using the <Tab> key when it says "root: ". (I'm assuming that grub followed the lead of lilo in using <Tab> to display the choices).I'm also assuming that you have grub. :D If you're using lilo, <Tab> will definietely work. The new kernel might have been installed, but not as the default.

If your new version ri\uns OK, then edit the config file for grun or lilo to make it the default, then run lilo or grub to actually install the changed version on the disk.

The kernel file will have been installed in /boot. Have a look there.

Jen C
06-06-2003, 08:51 PM
Thanks for the replies

I am using lilo and I am dual booting with windows. I have tried all your suggestions with no success :(.

>try using the <Tab> key when it says "root: "
Is this during boot up? It doesn't ever say "root:" The only prompt I get is "linux login:" which briefly displays. Pushing <tab> makes the cursor skip across the page, but that is all. Also tried pushing <shift> and then <tab> as decribed in the manpage of lilo.conf during booting with nil effect.

I have changed lilo.conf so that the new kernel is referenced. It now looks like this:
prompt
timeout=200
default=DOS
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
message=/boot/message
lba32

image=/boot/vmlinuz-2.4.20-18.8
label=linux
initrd=/boot/initrd-2.4.20-18.8.img
read-only
append="hdc=ide-scsi root=LABEL=/"

other=/dev/hda1
optional
label=Windows
I had a look at the grub.conf and it already showed the new kernel string:
default=2
timeout=10
splashimage=(hd0,5)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-18.8)
root (hd0,5)
kernel /vmlinuz-2.4.20-18.8 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-18.8.img
title Red Hat Linux (2.4.18-14)
root (hd0,5)
kernel /vmlinuz-2.4.18-14 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.18-14.img
title DOS
rootnoverify (hd0,0)
chainloader +1
>The kernel file will have been installed in /boot.
Yes, I can see the new kernel file in that directory.

> then run lilo or grub
hmmm ..... how does one "run" lilo? :8}. {feels an el thicko moment coming on :D}

As the (not being used) grub.conf file displays the new kernel file, I will assume that it installed OK. So, I am still stuck :(. I think more idiot proof instructions is required here.

Thanks for the help so far Chill and Graham.

Jen

bmason
06-06-2003, 09:12 PM
> > then run lilo or grub
> hmmm ..... how does one "run" lilo? :8}. {feels an
> el thicko moment coming on :D}

run 'lilo' at a root terminal. It will attempt to load the new settings.

Jen C
06-06-2003, 09:32 PM
> run 'lilo' at a root terminal. It will attempt to
> load the new settings.

OK, I did this and this is the message:

[root@linux root]# lilo
Added linux
Added Window
Fatal: No images have been defined
[root@linux root]#
I think the "Fatal" comment is trying to tell me something. So I need to defined the image then?? How would I do this?

Thanks
Jen

Jen C
06-06-2003, 09:49 PM
OK, I went and stuck my nose into the vmlinux-2.4.20-18.8 and had a look at the properties. Under permission there are no ticks at all beside Owner/Group/Other execute. Looking at the vmlinux-2.4.18-14 properties, I see that all three have ticks under execute. Do I need to add ticks here? Also, I see that there are two of each vmlinux files for each kernel version - one is about 3 MB and the duplicate is about 1 MB - is that normal?

Jen

Jen C
06-06-2003, 10:13 PM
back again!

Well adding ticks beside execute did diddlee-squat (apart from adding a rocket image onto the file icon). For good measure I ran lilo again and got the no image defined message again. Rebooting didn't help either.

hmmm ......

bmason
06-06-2003, 10:56 PM
The file permissions aren't relevent for booting.

The .img files are seperate from the kernel, but will need to be loaded.

I would recommend you copy the lines from linux and make a copy for 2.4.18 so your can boot the old kernel as a backup. (You will need to change the label).


The fatal error is because you haven't updated the default= line. It needs to be the name of a valid image. "Windows" in this case.

Jen C
06-06-2003, 11:09 PM
Good spotting on the default line! Thanks :D

...... and guess what!

I have the new kernel booting now - yipee!! :D

I had already made a copy of the original 2.4.18-14 before I started on this mission in case everything went pear-shaped.

Thanks bmason!

Jen :)