View Full Version : Excessive agression on rules on inbox - mystery deletions

03-06-2003, 12:07 PM
Am using OUtlook XP. Have noticed it takes a sudden dislike to emails from certain people. My sister for one.

Anyone got any easy suggestions? Her address is not obviously dodgy, and the email topic is pretty mundane. No words like enlargement or baldness.

Also, since I tried a hack in the registry to allow myself to see word docs in emails, it now forces me to save rather than open directly (which is a complete pain). I added extensions to Level1Remove and that doesn't seem to help. Any suggestions on that one?


Babe Ruth
03-06-2003, 02:50 PM

Not sure (yet) about your first point but you need to modify the registry to fix the second point re .DOC (and other) file extensions: see the following
Outlook_XP_Attachment_Security (http://www.astalavista.com/security/windows/officexp2.shtml)

This works a treat (tested - albeit some time ago... sorry should have mentioned...)

I will test your first point and get back to you via this thread.

Cheers, Babe.

03-06-2003, 03:06 PM
That's what I have done with the Level1 remove, but that just forces me to save it. That is a major hassle with things that I just want to view and move on. I get about three documents a week regarding soccer coaching, plus numerous other items where I just want to glance at something. If I have to save it I tend to decided whether I really want to look at it and don't bother at all with some things.

It adds additional steps to the process, and I never asked for it. I am sure it didn't do it a week ago, and I don't think anything has really changed. I can't see anything in the security section of outlook.

It is very annoying when the program takes over and the user is not given a choice. I can't think what I could have done to change it.

03-06-2003, 03:24 PM
>I can't think what I could have done to change it.
Funny you should say that,I thought that sort of thing only happened to the likes of me.

Jim B should be along soon,so cheer up.

Babe Ruth
03-06-2003, 03:33 PM

I have also used the COM addin mentioned in the follwoing url also to do what you want... Attachment Options (http://www.slipstick.com/outlook/esecup/getexe.htm). You may wish to use one of those instead of directly modifying the registry by hand...

Cheers, Babe.

Jim B
03-06-2003, 04:41 PM
The information on the link from Babe Ruth states -

After applying this registry fix or using one of the above tools, the user still has to save the attached file to a system drive before opening it. In effect, the fix rolls the attachment behavior back to Outlook 2000 SR-1, with its included Attachment Security Fix. An end-user cannot bypass this "save to disk" behavior and open the file directly from the mail message, though an Exchange administrator can.

You could of course just forward the message to your yourself and open it in Outlook Express
Or use a non MS mail client which does not suffer from all these security issues and at least gives the user the option whether to open an attachment or not.

To troubleshoot Rules Wizard rules ...

If you can't figure out which rules are operating on messages, add an action to each rule to assign a different category. When you look at a message, its categories will tell you which rules fired.

Babe Ruth
04-06-2003, 10:22 AM

One further utility which may be of use to you in getting outlook xp attachments sorted is Outlook_Attachments (http://camtech2000.net/Pages/Outlook_Attachments.htm)

Cheers, Babe.

05-06-2003, 09:33 AM
I just found this, but it applies to outlook 2000, and 97, not XP/2002.


Clearly a new security patch is to blame, but the registry entry mentioned here doesn't seem to have any effect.

I hate this sort of thing, changes without you knowing you are getting them. I have had to save about ten files in the last two days when I just needed to view them and move on.

Any ideas?


Jim B
05-06-2003, 11:18 AM
You have the choice of either not being able to open attachments at all or as you are doing saving them and then opening them.

If you are on an Exchange Server you may be able to configure it to do what you want.

See MS info here (http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3BQ290497)

Part of the enjoyment of using MS products which they are unable to make secure by any other means.
There are other email programs available.

05-06-2003, 12:10 PM
It's such a pig. I can believe it can't be changed, but I don't have Exchange.

It's driving me nuts. I reckon I am wasting a huge amount of time with this. It lets me double click and open txt files.

Any ideas appreciated.
I am continuing to research this.

Babe Ruth
05-06-2003, 12:54 PM

I guess you have applied Service Pack 2 for Office XP... but have you also seen the MS article OL2002: You Cannot Open Attachments (http://support.microsoft.com/default.aspx?scid=kb;EN-US;290497) which goes to some length on the attachment blocking but not necessarily a total fix. There are some hints as to what the issues may be .... Will get back more info when it arrives.

Cheers, Babe.

05-06-2003, 12:57 PM
Article 278144 on the microsoft knowledge base talks about situations where you want to treat text files like docs, etc. It appears you need to add exceptions before you upgrade from 2000, which is ridiculous if you are doing a new install.

I cannot find anything to help me get out of this. It is far more than an annoyance if I have to repeat this farcicle routine in the interest of security I don't even want. I used to use Wordview in the old days which made macro viruses impotent, but I don't think that would even help now as the code is tied in to outlook.

This whole area is a snakepit that you fall into when you do as you are told and add patches. I am not happy about this at all.

I can't easily change to another email client as I use the calendar and contacts and they integrate to the pocket PC and Palm. I have to try to find a solution elsewhere.

05-06-2003, 01:15 PM
Believe it or not, I got this from someone at Microsoft tech support, and he was pretty helpful.

We went through the whole level1 remove thing, yada, yada, yada, but then we found out something:

Under SP2, it forces entries in level1remove to save. All I did was take out doc and xls from the list and I can open them again! Happy day, oh joy, delerium.

So the registry hack from before to fix a problem created a new problem after the SP2, and reversing it slightly solves the problem.

Thanks for efforts of you all, and big bouquet to Microsoft Services.