PDA

View Full Version : LINUX Kmail won't start for main user (me)



Clueless
19-05-2003, 08:08 PM
I logged in a few minutes ago and Kmail spat the preverbial. It tried to start, the little icon at the end of the mouse flashed for a bit and then stopped. Nothing else happened.

I logged out and back in as user "pugwash" (yes my dog has a user profile) and opened Kmail. It happily started, even though it had to make some files for this new user. (Pugwash hadn't set up her email stuff)

So i figure there might be some corruption of my mail files that kmail doesn't like.

2 questions:
-Where might i find logs on kmails failure?

-and um..... help!?

.Clueless

bmason
20-05-2003, 03:05 PM
Starting it from a terminal windows should give you something.

If you have to delete its configuration stuff, its kept in ~/.kde/share/apps/kmail and ~/.kde/share/config/kmailrc . It won't affect your mail because it should be stored in ~/Mail . I'm not sure where it keeps the addressbook.

Clueless
21-05-2003, 10:58 AM
Some progress has been made here. I dismantled the ~/mail directory, as it seemed that that was the cause. Ultimatly i moved all the components to a directory i called ~/maildump and deleted ~/mail

I restarted Kmail, it started, but of course had to create a new directory called ~/mail as there wasn't one. I was surprised that it knew to go and get mail from all the right places, one assumes these settings are in one of the directorys mentioned above. It also knew to try and put any mail for my main address in the now non existant folder i had once made for that mail, causing Kmail to crash within the first minute. I've gradually put all the parts from the ~/maildump directory into the new ~/mail one, and it seems happy.

I note that Sam has only been running for just over a day, which is probably the result of flakey power forcing reboot. I think this scenario is good for showing why people have UPS on their servers. :( bloody CHCH power!

.Clueless