PDA

View Full Version : Increasing Screen Res. in RedHat 9



Chilling_Silently
22-04-2003, 08:43 PM
Having just removed all my previous Linux installs, Ive setup RH9 all fine :-)

Only problem is the screen res would only let me set it to 800x600 during setup, and I want it back to my fav of 1024x768, be it at 60,70,72, or 75Hz, I dont care!

Now, I used the GUI config to change it and rebooted to no effect, and checking the XF86Config file, there's the option for 1024x768 in there.. Its just using 800x600 as default.

What am I doing wrong?

Cheers


Chill.

Dolby Digital
22-04-2003, 09:18 PM
Have you tried cycling through the available resolutions Ctrl - Alt - +/- (on the num keypad). Maybe its there... maybe its not.

Chilling_Silently
22-04-2003, 09:21 PM
No, but I will try that thanks :-)

If it works, is there a permanent way to set it to use the higher Res.?

If it doesnt, Im still at square one..

I'll post in the morning coz Im in Win2K at the moment :-)

Thanks!

Kame
22-04-2003, 09:25 PM
In XF86Config file it shows sizes of Screen Resolutions. I think you just add the size you want and delete the rest. Or you just make sure the size you want is at the start of the line and leave the rest how it is. Don't know exactly, I've only had to do this once. but obviously you'd back up this file before attempting this.

b1naryb0y
22-04-2003, 09:25 PM
Before I start, can I assume that you are using XFree86 version 4.xx?

If you are there is every possibility that apart from a XF86Config there is also a XF86Config-4 file. If you have both then you will need to edit the XF86Config-4 one because this is the native config file for verions 4.00 and higher. If there is no XF86Config-4 then your system will default to using the older XF86Config format.

Now look in the appropriate file for a line that starts with "modes".

It should look something like this

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection

Note that you may have several of these, each with a different value in the "Depth" field. The depth in this example is obviously 16 bit.

You will see that the resolutions go from right to left, well this is the order in which they are loaded in. So if you want the default to be "1024x768" then make sure that is listed first. You will need to change this for all the different colour depths.
If you also want to change the default colour depth then add this line under the line 'Section "Screen"'

DefaultColorDepth 16 (or what ever colour depth you prefer)

And take not of how "Color" in DefaultColorDepth in spelt, the missing u is deliberate because the crrect syntax is in U.S. English.

Now I know I've ranted on and I've probably just confused you more, but if you run into trouble just let me know.

b1naryb0y
22-04-2003, 09:27 PM
"You will see that the resolutions go from right to left"

whoops that was supposed to read

You will see that the resolutions go from left to right!

Chilling_Silently
22-04-2003, 09:29 PM
Well... Comprehensive... Thanks :D

I'll post back in the morning when Ive given it a shot :-)

Kame
22-04-2003, 09:38 PM
RH9 obviously does have version 4.xx and as for the native config, I think it's only got the one which is XF86Config-4 so when I say XF86Config it's referring to the one that is present.

Now that you've shown me how it looks I remember that I changed it to:

Modes "800x600" "1024x768" "640x480"

what this did was change the screen size to 800x600 but the "1024x768" in the middle made me have to scroll to see everything showing on the desktop. (was converting 1024x768 to 800x600) so I just deleted 1024x768 and left 800x600 and 640x480.

All you have to do is add the modes "1024x768" "800x600" "640x480" and that should be it.

JohnD
22-04-2003, 09:41 PM
My install of RedHat 9 is still a day or so away - but they have done away with the tool Xconfigurator I believe and replaced it with "redhat-config-xfree86". I am not sure but it might be available in the GUI? This might save editing the text file?

Chilling_Silently
23-04-2003, 08:22 AM
Okay, adding stuff to the 'Modes' section makes stuff all difference, even with Ctrl + Alt + NumPadPlus....

I tried man XF86config and added something like UseModes 1024x768 or something.. didnt work with or without quotes and crashed my X server.

So far no joy people, any other ideas? Im still stuck at 800x600, even though Ive added 1024x768!

Thanks


Chill.

Chilling_Silently
23-04-2003, 09:10 PM
Had a read thru the man pages and it wasnt any help.

No other config files to edit..

Should I see about updating the driver? Im currently using the standard RH9 nv driver :-)

bmason
23-04-2003, 11:00 PM
It might be your monitor settings.

Have a look in /var/log/XFree86.0.log for lines like:

(II) RADEON(0): monitor1: Using hsync range of 30.00-71.00 kHz
(II) RADEON(0): monitor1: Using vrefresh range of 50.00-160.00 Hz
(II) RADEON(0): Clock range: 20.00 to 350.00 MHz
(II) RADEON(0): Not using default mode "320x175" (bad mode clock/interlace/doublescan)
(WW) (1400x1050,monitor1) mode clock 122MHz exceeds DDC maximum 110MHz
(II) RADEON(0): Not using default mode "1400x1050" (hsync out of range)
(II) RADEON(0): Not using default mode "1280x1024" (width too large for virtual size)
etc.


It will tell you what modes its throwing away that it thinks won't work with your monitor.

Chilling_Silently
24-04-2003, 09:46 AM
Ah, well.. Id say that's right due to an error I got with it when playing round with the config file, but Im gonna have to leave RedHat for now, formatting the partitions coz Im moving around my HDD's and putting sum in other PC's etc.

Selling. Upgrading.. buying a CD-R/W and all my IDE places are taken an I dont wanna fork out for a PCI IDE card.... Anyways, thanks:-)

Cheers


Chilling_Silence

JohnD
26-04-2003, 07:58 PM
I have just installed RH9 (dual booting with RH7.3). I also didn't get the option beyond 800x600 during setup. I used the graphical setup for the screen resolution but it didn't work - I could select 1024x768 but after restarting Xwindows, it was back at 800x600! On about the 4th go, it (magically) worked!