PDA

View Full Version : How do I access a second CD-ROM drive in Linux?



forrest44
08-04-2003, 07:01 PM
I installed a CD-RW (e: in windows) drive with a CD-ROM drive (f: in windows), and can only find the directory for the CD-RW drive in linux (/mnt/cdrom/ or something). I cant seem to access my CD-ROM drive any more (although I can play audio CDs off it by entering the path '/dev/cdroms/cdrom1' into the CD player path setting in a CD-player app).

What do I do to access it in linux?

Graham L
08-04-2003, 07:14 PM
Make a second mount point. (as root) "mkdir /mnt/cdrom1", say, then edit /etc/fstab to make a second line for CDs. Copy the existing line and change the /dev ... and mount point names to suit.

JohnD
08-04-2003, 10:03 PM
If you want to make the CDRW work in Linux have a look at:

http://homepages.paradise.net.nz/jsd/John/Linux/cdrw.html

Clueless
09-04-2003, 10:53 AM
Sorry for jumping on this thread with a similar question, I think that's better than splitting & duplicating the answers.

I just moved my CDRom from Sec-master to Prim-slave
The line in /etc/fstab reads:

/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0

So what do i change?????

.Clueless

JohnD
09-04-2003, 12:23 PM
Your CD-ROM was on device hdc and you have moved it to hdb. So I think you need to link the new device to /dev/cdrom:

ln /dev/hdb /dev/cdrom (spaces after ln and hdb)

Clueless
09-04-2003, 02:02 PM
hippy@sam:~> su
Password:
sam:/home/hippy # ln /dev/hdb /dev/cdrom
ln: `/dev/cdrom': File exists

Me thinks i might need to unlink something first????
Trying to mount the CD using the desktop icon produces:


Could not mount device.
The reported error was:
mount: /dev/cdrom is not a valid block device

.Clueless

Graham L
09-04-2003, 02:21 PM
/dev/cdrom is a link to the actual device entry. That's like /dev/modem, etc. It makes it easy for programmes which use such devices directly (rather than through the file system) to access them, when they could be
"physically" at any number of places. You need one /dev/cdrom for the audio players etc. You will have to choose which one you want to put audio CDs into. :D

Fopr the /etc/fstab table entries, it odesn't matter whether you use the ?dev/cdrom" or the actual /deb/hdb (or whatever). I actually prefer to have the true device identifier there.

To change the link, "rm /dev/cdrom" first. It's a device entry, so there's a bit more protection against accidents. I think there's a force option to the ln command, but it's just as easy to remove the link first.

Clueless
09-04-2003, 03:11 PM
sam:/home/hippy # rm /dev/cdrom
sam:/home/hippy
sam:/home/hippy # ln /dev/hdb /dev/cdrom
sam:/home/hippy #


And now sam knows where the CD is, and i'm able to use it.
Ta for that.

.Clueless

Graham L
09-04-2003, 03:16 PM
I always use "ln -s", to make "soft" links rather than "hard" links. I'm not sure whether it's a bad idea to use hard links for /dev entries . ;-)