PDA

View Full Version : IE 5, Win 95 & Net connection



Halwende
04-04-2003, 09:09 AM
PC is a Pentium 133 with Windows 95. User wishes to load MSN Messenger for her daughter.

Originally had IE 3 loaded, no net connection. Messenger requires 4 or above. I installed IE 4 and set-up dial-up connection to their Xtra account. Logs on fine, attempted to browse however when it's retrieving a page it says "internal error with Internet extensions".

Tried re-installing IE 4, no luck. So, after checking IE 5 is ok for Win 95 I installed that but now it's just the "...page cannot be displayed" I get each time I try to open a web page.

Modem connects at 33kps, bytes are being sent and received each time I enter a URL and hit Go but after a few seconds it tells me it cannot be displayed. All settings are at default, I tried switching down to Low security and tried with some settings under Advanced but no luck, so I reset them back to default - still the same.

What can I do to diagnose the cause? The modem connects and it's sending and receiving but IE won't display anything. MSN Messenger 4.6 is installed too - is it a software setting somewhere?

No firewall is installed, no other background nasties either - makes me think it's either a IE 5 or MSN Messenger 5.6 setting? Nothing out of the ordinary in Modem settings either, but I don't want to rule that out.

Please help with some things I can try, as I won't be able to look at this PC again until about 6pm today (Fri 4th April) ...

Halwende
04-04-2003, 09:11 AM
It's Messenger 4.6, not 5.

MSN Messenger 4.6, Internet Explorer 5.0 (40-bit security)

CYaBro
04-04-2003, 09:14 AM
While connected to the net open up a DOS windows and try ping a website by the URL and IP address.

i.e. ping www.pressf1.co.nz
and ping 210.48.100.45

See if you get a response from both.
Post back with results

Gorela
04-04-2003, 09:39 AM
Do as CYaBro has suggested as "page not found" normally points to a DNS error. By the sounds of things pinging the IP address should work and pinging the http:// address shouldn't. If this is the case you will need to check the properties for the xtra account.

Ensure that the DNS is set to automatically assigned rather than user defined. Also try accessing a site with IE that you know never causes problems perhaps genuki (http://www.genuki.org.uk/big/) which has very little in the way of graphics and can start loading reasonably fast.

HTH

Halwende
04-04-2003, 10:26 AM
I'll try as you both suggest tonight and ping some IP addresses, I'll also add another dial-up connection with my Paradise.net account and see if I get the same thing.

If I get no response from the pings what would be the next step to resolving the DNS error?

Which properties of the xtra account are you referring to Gorela? Do you mean the protocol?

Thanks for the feedback so far

Chilling_Silence
04-04-2003, 11:23 AM
You'd have to adjust the Dial-Up account settings, perhaps specifying a DNS server.

A DNS server basically converts Domain Names (DNS = Domain Name Server) like http://www.pressf1.co.nz into http://210.48.100.45 which directs you to the PC that PressF1 is held on.

If you're not getting the DNS stuff, you'll have to tell your PC to go to a specific server, like Xtra's.

MSN Messenger and ICQ should still work though, even if Internet Explorer doesnt?

if you can ping 210.48.100.45 and it DOESNT come back saying:
Could not find host
or something similar, then try typing:
http://210.48.100.45
Into Internet Explorer and see how that goes :-)


Cheers


Chilling_Silence

Gorela
04-04-2003, 05:08 PM
Just for the record xtra is one of the ISP's that automatically assigns the DNS server address. As it's part of their handshake protocol the user doesn't set this up.

Paradise on the other hand does need them to be assigned.

As far as the location of these settings they are most likely in the Dial-up Settings. You may have called the connection "xtra" and there should be an area called advanced settings. I'm trying to remember if the set-up wizard would have made mention of these settings, but it escapes me at the mo :8}

Antonia
04-04-2003, 07:12 PM
The xtra website http://xtra.co.nz/home/ has a very good Help and Support section, which lists all the correct settings for windows 95, Internet Explorer, dialup, network etc.

Checking your settings against those may help you.

Regards, antonia

Halwende
05-04-2003, 12:21 AM
Ok, here's the rundown, hopefully someone
can help me from here!

1. Connected, tried to ping 210.48.100.45
via DOS and received "transmit failed, error
code 10043" (x4), same for pinging http://210.
48.100.45

2. When pinging http://www.pressf1.co.nz I
got "Bad IP address"

3. Went armed with multitude of printouts
of web pages off xtra.co.nz and checked all
the settings of dial-up connection and IE
settings against what they have and re-tried
steps 1 and 2 above, no change in result.

4. Changed DNS server setting to xtra's
recommendation of 202.27.184.3 for primary
and 202.27.184.5 for secondary, re-tried
steps 1 and 2 - still the same.

5. Paused for a moment to consider throwing
PC onto the ground and going home to play
Unreal Tournament 2003, thought "better not".

6. Added my Paradise.net connection as a
second dial-up icon, still the same results.
(Same settings as working ones @home)

7. Tried adding xtra's proxy server (as one
set of instructions says) and can see that IE
talks to proxy server for split second (or
gets ignored by it) and gives me "Page Cannot
be Displayed" anyway.

8. Said I'd come back Monday, went home to cry.
(ok maybe not, put to post this and maybe a
little UT2003...)

I'm stuck! I've had Win95 PC, a Win98 PC and
now my WinXP Pro and I've never had so much
trouble with anything in all my years! I'm no
IT professional or network admin guy so it's
all still at an amateur level, but still it's
quite frustrating!

Feedback/advice on what to do next very much
appreciated...!!

Jim B
05-04-2003, 01:15 AM
Go to Control Panels/Network
Remove all protocols except Client for MS networks, Dialup adapter and TCP/IP

Go to your Dialup connection properties and click on server types and untick everything except Enable software compression and TCP/IP

Restart and try again

If that does not work remove all Network Protocols and reinstall Client for MS networks, Dialup Adapter and TCP/IP make sure you have the Win 95 CD handy.

Repo74
05-04-2003, 01:04 PM
Hi Halwende,

I found this fix for DNS errors on the net one day and tried it, needless to say it works. Have never had to worry again. Try it and let me know if it fixes your problem


DNS ERROR FIX for Windows 95 98 and ME


Go to add/remove programs in the control panel.
Go to the Windows Setup Tab.
Uncheck Communications.
Click apply
Click OK
It will ask you to reboot

DO NOT REBOOT. Say NO


Leave the control panel up.

Go to Start/Run/ Type in regedit

Highlight My Computer on the left. At the top of the registry editor,
click Registry/Export registry file. Save it to your desktop, call it backup.reg.
Make sure the Export Range at the bottom is set to all.


Once the registry is backed up, browse to each of the following keys in the registry and

delete them.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\VXD\AFVXD


HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\VXD\DHCP


HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\VXD\MSTP


HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\VXD\Winsock


HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\VXD\Winsock2


HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\Winsock


HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\Winsock2


HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\RemoteAccess\Authentication\SMM_Files


Close the registry editor.

Go back to Control Panel.
Double click add/remove programs.
Go to the Windows Setup Tab.
Highlight the word Communications (NOT THE CHECKMARK BOX) and click details in the bottom

right.

Put a check in Dialup Networking.
Click Apply.
Click OK.

It will ask you to reboot. this time REBOOT.

When you get up and running again, try connecting to the net and browsing. IT WORKS

Regards Repo74