PDA

View Full Version : WinXP and IPX



bmason
14-01-2003, 11:47 PM
hi all,

I'm trying to get Tiberium Sun running over my lan between a couple of win 98 boxes and an XP home machine.

It works between the 98 machines, and it works over a parallel cable connection to the XP box, but not over the network.

I've reinstalled IPX and have them all using the same frame type.

Has anyone got any suggestions to get the XP box working?

Chilling_Silence
15-01-2003, 09:01 AM
Can it not use TCP/IP - as that would be a better option. I havent managed to get it going in 2K either, but it hasnt been on my "High-Priority" list.

There should be an option for specying the Hosts IP Address, use that method of connecting.

To find somebody's IP address on a LAN, click Start
-Run
type
cmd or command, whichever works
type
ping otherPCnameGoesHere

That should be a good work-around for the IPX/SPX protocol :)

Cheers


Chilling_Silence

yang11
15-01-2003, 09:48 AM
I got RA2:yuri. there is also a network number to investigate. both in game and in windows network ipx properties.

my os is w2k, and my flatmate machine is xp or 2k. we just fiddled around and it worked. sorry I cant remember the exact details.

if possible, make sure a different serial number for each machine.

agent
15-01-2003, 10:46 AM
I think this is my personal opinion, but IPX is nasty. On my old home network, if you enabled it on a client computer, the server did not like it.

Isn't IPX kind of like CGI - old, slow, and crap?

Chilling_Silence
15-01-2003, 10:55 AM
Yeah.... well.. It has been surpassed by TCP/IP AFAIK in almost everything..

agent
15-01-2003, 10:58 AM
I enabled TCP/IP version 6 on my XP SP1 comp... apparently you have to download an unsupported driver to get it working on 2000 or anything non-XP. I think from memory v6 is also unsupported as it was in beta or something?

Ah, who cares, my thoughts are "latest = greatest", hence why I always download beta versions of software (and never have a problem with them :))

tweak\'e
15-01-2003, 11:24 AM
> I think this is my personal opinion, but IPX is
> nasty. On my old home network, if you enabled it on a
> client computer, the server did not like it.
>
> Isn't IPX kind of like CGI - old, slow, and crap?

not really. ipx/spx is quite fast, will handle medium sized networks and is way easyier to setup than tcp/ip. plus it not routable over the net so it makes sicurity a little easier. netbeui is the easyest to get going but it seems to be a little iffy at times.

i ussually run ipx/spx with windows networking as the tcp/ip is tweaked for the modems which slows the whole tcp/ip networking down.

bmason
15-01-2003, 08:07 PM
Nope its IPX only. I hate westwood.

It magically started working last night with both Tiberum Sun and Half-life (not that it needs IPX).

Unfortunately the magic had worn off when I started it up today :-(.

tweak\'e
15-01-2003, 08:34 PM
have you got netbios over ipx/spx enabled ?

bmason
15-01-2003, 10:57 PM
Its currently enabled, I've also tried with it disabled. The 98 boxes don't seem to care either way.

I think XP is messing with it because both the client and server direct cable connection stuff has disappeared overnight.