PDA

View Full Version : linux mandrake9.0



orcha
09-01-2003, 06:17 PM
Hi I have just installed mandeake 9.0 and everything ran smoothly and worked except you guessed it my modem. I have choosen the right port but still get no response from modem.
My modem is a dick smith XH1154 and comes with linux drivers but trouble is being a linux newbie I can,t work out how to install the drivers.
Can anyone help?
Thanks.

Graham L
09-01-2003, 06:23 PM
Did the DSE drivers come on a CD? Put it in, and click on the CD icon to mount it. Browse for a Linux directory. The file you need probably be .RPM type, but there will probably be a Readme text file to read, too (so read it ;-)). Right-clicking on the appropriate RPM (compressed package) file should give you an "install" option. You will have to be logged in as root to do that.

orcha
09-01-2003, 09:37 PM
thanks graham the drivers are on the cd I will try that . Am I right in saying that if the modem is on com4 under windows it is on ttyS3 under linux?

E.ric
09-01-2003, 10:37 PM
copy and paste from DSE website,
___________________________________

DSE Modem 56K - PCI Int HaM v2
The DSE Internal PCI 56K Modem uses a new Intel chipset with Host Accelerated Modem (HaM) technology to deliver superior performance - compatible with both Windows & Linux - supports V.92!
Cat No. XH1154
NZ$68
___________________________________

Good to see it is not a WIN MODEM
I had a 33K standard modem, as I went to 56K and was giving linux a bit more interext , got a 56K external one, they say external ones are more reliable sorry I can not help more, but linux picked up the internal one OK.

Chilling_Silence
10-01-2003, 08:48 AM
> Am I right in saying that if the modem is on
> com4 under windows it is on ttyS3 under linux?

Yes, in Linux, the com ports start a ttyS0 with that being com 1!

orcha
10-01-2003, 09:58 PM
Right i,ve now got this far .
I've extracted the file to a directory it was a .tgz file
Then I logged in as root
Then I cd to the directory the driver was in
Then I typed make clean
Then I typed make 536ep
This was as far as I got as I got an error cannot find /lib/modules/autoconf.h
I was supposed to type (make install) next but this did not work due to the previous error.
This was to the instructions in the read me
Can anyone help now?.
Ta Aaron.

Shaun Minfie
11-01-2003, 10:40 AM
Make sure you have the kernel source installed

Graham L
11-01-2003, 02:35 PM
For the "make" to work you must have extracted the files (BTW a .tgz = a tar archive which has been gzipped, which sometimes has the "extension" .tar.gz) ...

I will obviously have to start using these later versions :D. /lib/modules/autoconf.h is a new one to me. It is a C header file, which will make some definitions, and even add some code to autoconfigure the module when you make it. It may have come in the archive file ... have a look in the directory you extracted it to (though I think the C compiler would have found it there, but it may have been put into a subdirectory). If you find it there , do "cp autoconf.h /lib/modules/". If not, search for it ("find /usr/src/linux -name modules.h") . If it's not there (expecially if there isn't a "/usr/src/linux" ;-) ) you haven't got the kernel sources installed. They are "usually" installed with the "development" option which installs the compiler stuff, though.

Graham L
13-01-2003, 02:55 PM
Perhaps ... did the instructions include "./configure" before any of the "makes"? That might produce the missing file. And if you missed out that step, ;-), ...

Dolby Digital
13-01-2003, 04:47 PM
try, logged on as root: find / -name /lib/modules/autoconf.h -print

to see if its on your system. It maybe under a directory like 2.4.19mdk