PDA

View Full Version : Linux Date Settings



merlin-nz
09-01-2003, 04:54 PM
Hi people,

The date on my Linux, Mandrake 9.0 box is always one day ahead of me and the rest of NZ.

The time is ok just the date, I change it every time I log into Linux and its ok until I log on the very next time, (but if I log straight back on say 5 to 10 minutes its ok) only if its left until the next day, say about 12 hours?

Any reason for this and is there a simple way to fix not that worried but can be a little desconcerting.


cheers merlni-nz ;-)

godfather
09-01-2003, 05:19 PM
Are you sure its not just 12 hours out? If displaying in 12 hour format.
Then you would be a day ahead of yourself for half of every day.

godfather
09-01-2003, 05:22 PM
Further to that look on PF1 search for linux clock bios.
Graham L makes the point that Linux only looks at the BIOS clock when told to, or at boot up. Try correcting it in BIOS?

Graham L
09-01-2003, 05:27 PM
Sounds plausible. :D

You have set the Time zone to +1200. Your battery clock on the motherboard is set to NZ (local time). Unfortunately, your Linux system has assumed that the MB clock is on UTC (GMT). ;-)

You correct the time each time you boot Linux. That stays "correct" for the rest of that session. The next time you boot, it fetches the date and time from the MB clock. That's the only time it looks at the HW clock. It doesn't write to it unless it's told to.

Yes, there is a setting for local/UTC. I would suspect that it will be one of the questions which it asks when you set the timezone. Or you could set the time correct in Linux, and issue the command "clock -w" to set the MB clock to UTC.

If you are dual booting with Windows, you will then get a problem with the Windows time. :D If it's a straight Linux machine, it's a matter of choice.

merlin-nz
10-01-2003, 12:00 PM
Thanks guys,

I played a bit in <Adjust Date and Time under root> and entered the time in 24 hour format (I think), and this morning all is ok (touch wood).

Its even showing the am and pm when i right click on the clock and select Date & Time format.

so cheers guys merlin-nz ;-)