PDA

View Full Version : XF86Config



nz_liam
27-12-2002, 01:49 PM
Windoze NT is broken again :_|, so I'm having another play with RH8 instead of fixing it. :D

However I cant find where to set the default refresh rate; currently I'm running at 1024/768 resolution, and 48K/60HZ frequency, and to put it mildly gives me a hedache after 30's of use.

Currently my "/etc/X11/XF86Config" file looks like this # XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "PHILIPS M107"
DisplaySize 310 230
HorizSync 30.0 - 71.0
VertRefresh 50.0 - 160.0
ModeLine "1400x1050" 129.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 151.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 162.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 184.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Modes "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

What do I have to change to make the refresh rate default to 85HZ ?:|


Cheers

Liam

Graham L
27-12-2002, 03:51 PM
I believe that NVIDIA cards are a bit tricky. Because they are popular, problems will be fixed fairly quickly.

I see that you have "generic" software for it. Did you load drivers from the nvidia site? It would probably be a good idea. I think there are some "howto" files on that site. "nvidia linux" will find their site, and there's also a lengthy article which is worth a look.

nz_liam
27-12-2002, 06:34 PM
Thanks for the reply; I would have a look at the NVIDA site (I belive it is www.nvida.com), but it seems there site is down:A server error has occurred. ((42000) [Microsoft][ODBC SQL Server Driver][SQL Server]Cannot open database requested in login 'zoneedit'. Login fails.)

I might try using an older driver in the meantime say geforce2 and see wether that helps.


Cheers

Liam

nz_liam
27-12-2002, 06:42 PM
Well using the GeForce2 Generic drivers instead of the GeForce4 drivers seem to have fixed the problem, I am now running at 1024/768 and 69K/85HZ, so at least I can now read the screen.

I will try and get the new GeForce4 drivers of the NVIDA site when it comes back online.


Cheers

Liam

bmason
27-12-2002, 09:06 PM
The problem was the line:

Driver "vesa"


It was using the standard VESA driver, which can't do nice refresh rates.

The opensource (2d only) driver is called "nv", and the NVidia ones are called "nvidia".

IIRC both drivers will detect the card type, the board/vendorname is just for display.