PDA

View Full Version : Can't turn off Task Scheduler



mark c
05-10-2002, 12:27 PM
In win98se I go to the systray, open TS, /advanced/stop using TS/ and OK it dissappears but at every boot up it's back. I had a look in startup in msconfig and can't find it but there is a Task Monitor. Would that be the same thing?

I kind of doubt it. Small issue I know, but an irritant.

Cheers, Mark c

godfather
05-10-2002, 12:34 PM
Select Start, Programs, Accessories, System Tools, Scheduled Tasks to open the Task Scheduler. Now select Advanced, Stop Using Task Scheduler. The program's icon will disappear from the tray of your Taskbar, and the scheduler will no longer start when you start Windows 98.

mark c
05-10-2002, 12:43 PM
Ho well thanks a mill, GF, but it didn't work!

Did all you suggested and then rebooted and dang, there it is in the systray again. It wouldn't be Task Monitor in MSconfig would it?

Thanks but :)

Jester
05-10-2002, 12:53 PM
Look here:
http://www.pacs-portal.co.uk/startup_pages/startup_full.htm

Wait till the page loads, and then go to "T"

Task Monitor: taskmon.exe

The Task Monitor checks the disk-access patterns of programs when they are started and stores this information in log files in the Applog folder. Task Monitor also records the number of times you use a program. The Disk Defragmenter tool uses this information to optimize your hard disk so that programs that you use frequently are loaded faster. Not required - but can be useful. Note: for Norton Anti-Virus 2002 users, loading TaskMonitor will typically solve many, if not most, of those annoying IE scripting errors (per Symantec's Knowledgebase)

Now, scroll back up to S

Scheduling Agent: mstask.exe & mstinit.exe

Microsoft Scheduling Agent displayed as a box with a stopwatch in the System Tray that is only needed if you have regular scheduled disk defragmenting, ScanDisk, etc. I'd recommend you run these at regular intervals manually as they can interrupt other programs

I think Scheduling Agent is the one you need to disable.

J
:D

mark c
05-10-2002, 01:06 PM
>
> I think Scheduling Agent is the one you need to
> disable.

Hey thanks for that and yep sure is, but cleared up difference between Task Mon. and Task Sched.

Does it matter?

Nah not really, I just have so few computer problems that I have to go looking for things to fix up.

LOL. And the reason I have so few probs. is because I don't do very much. Confession #1. Never yet had the case off a working computer. Taken dead ones to bits that's all.
Thanks for your help both, but still haven't killed the critter. :D

Susan B
05-10-2002, 10:05 PM
Open Win Explorer, click on Scheduled Tasks then on the Toolbar click on Advanced then Pause Task Scheduler.

mark c
06-10-2002, 08:27 AM
Thanks Susan B, but that doesn't get rid of it either. OK it's paused, b ut I wanted it out of the systray.

Never mind.

:) 2 u all.

Susan B
06-10-2002, 03:47 PM
What about if you open Win Explorer, click on Scheduled Tasks then on the Toolbar click on Advanced then Stop Using Task Scheduler? Are you able to do that or does it say "Start Using Task Scheduler" like mine does?

Mine is totally disabled and I don't have any icon in my tasktray.

Also, in the list of items in the Scheduled Tasks folder do they all have a "Disabled" status? If any don't, right click it choose Properties and remove the tick in Enabled. Then to get rid of the icon on your tasktray right click it and see if there's an option somewhere to close it for good.

If that doesn't work, I give up.

Jester
06-10-2002, 04:21 PM
My last guess (actually it's what I would have checked first), would be to check that it isn't in your StartUp programs under Start - Programs - Start Up. Even if you disabled it everywhere else it will re-start on reboot if it is still sitting in this folder.

J.
:D

Terry Porritt
06-10-2002, 04:24 PM
I suppose you have tried running msconfig - Startup, and removing the tick from Scheduling Agent?

On the other hand this is where Winalign runs from, so it's not a bad thing to keep the Scheduler running so that when you defrag, the hard drive is optimised. It doesnt take up much in the way of resources.

Terry Porritt
06-10-2002, 04:30 PM
Should have added Winalign aligns MS programs, and only needs to be run once in a while, so if you dont have tasks scheduled its not that important to have Task Scheduler running I suppose.

mark c
10-10-2002, 07:49 AM
Thanks v. much everybody, I tried everything and it won't go away. The long arm of MS cannot be avoided, maybe. I even tried deleting the contents of Task Scheduler but no. Must be all defaults.

Cheers, :D Only an irritant anyway. I'll go do something useful.

MarkB
10-10-2002, 09:46 AM
To stop this happening in 98se, i usually go to msconfig/start up and remove the tick from scheduling agent.
This starts up mstask.exe.
Also after removing the tick click on ok, dont just exit out.
If this still doesnt work then try removing it altogether by using something like regcleaner(free), or system mechanic(not free).

cheers

mark c
10-10-2002, 10:07 AM
>>This starts up mstask.exe.

Not quite sure what you mean by this. Have done what you suggested, thanks, and maybe try this mechanic. :)

MarkB
10-10-2002, 10:33 AM
What I meant was under startup tab in msconfig there is a line that will look smething like-

(box) SchedulingAgent mstask.exe

this is what I unticked then clicked on ok.

The regcleaner and system mechanic allow you to remove this entry altogether by using the startup list tab option in each program.

mark c
10-10-2002, 11:12 AM
Oh I see. Thanks :)