PDA

View Full Version : Source codes showing at top of web pages



Iain
23-09-2002, 03:17 PM
This morning I duly followed the advice of M$ via their critical updates notification and updated my browser from IE6 with the "Service Pack 1" for Win 98 download. I used the manual option and didn't download all the options as I don't use outlook or media player, but don't recall which ones aside from the IE 6 update I did download as It didn't seem important at the time.

However, now when I view most, but oddly, not all, web pages the first few lines on the screen are the same text I would see if I chose to "View source" in the menu. For example, this page starts: "!HTTP/1.0 200 OK Content-Type: text/html;charset=ISO-8859" and goes on for four lines before actually starting the webpage. Perhaps ironically, Hotmail is impossible to use as there is so much text you can't read the messages.

My internet brower settings all worked fine until the update, so clearly some setting has changed, but I can't work out how to describe it to look for help on it. My connection is on Jetstream so it may be related to that, or the fire wall software (Zone Alarm), but as I say, I can't work out how to even describe the problem in order to do a sensible search for help on it. My reading of comments on other sites about the SP have found discussions about whether the SP does or does not fix the security bugs described. None have mentioned the problem I have experienced.

Any help apprecaited.

IAIN

Chris Wilson
23-09-2002, 03:49 PM
Your problem wont be isp/connection related.

You could try rebooting , it might just be a fluke thing..
it sounds like it is ignoring the first bit that says
<html>
<head>

Could you copy and paste some of the top of page garbage into a post for us?
This ones got me really curious again!

Does it do it on other browsers?
Perhaps its time to join the move to opera as your main browser!

Iain
23-09-2002, 04:05 PM
Chris.

Thanks for the speedy reply. To answer your questions, re-booting (more than once today) has not had any effect on the browser. I don't have any other browsers installed so can't say if they have changed or work differently. I could change to another one, but I fear that other less computer literate users of my computer will probably want to persist with IE.

I suspect the problem may have something to do with the handling of Java scripts as a webpage I use frequently which is customizable to show times for cities in other countries wont load in Java aplet form, but runs fine in HTML form. The Java form always ran fine until today.

The text at the top of the page is always the first bit that I see if I show source codes. For example, here is the text from thop of this page: !HTTP/1.0 200 OK Content-Type: text/html;charset=ISO-8859-1 Proxy-Connection: close Server: Apache/1.3.23 (Unix) (Red-Hat/Linux) mod_ssl/2.8.7 OpenSSL/0.9.6b DAV/1.0.3 PHP/4.1.2 mod_perl/1.26 Date: Mon, 23 Sep 2002 02:53:26 GMT

It's the same as the source code as far as I can see.

This is from Google:

!HTTP/1.0 200 OK Content-Type: text/html Cache-Control: private Proxy-Connection: close Server: GWS/2.0 Date: Mon, 23 Sep 2002 02:55:21 GMT


Maybe some of this helps.

IAIN

Chris Wilson
23-09-2002, 04:21 PM
thats not the top of the html

this is (for this page)
<html>
<head>
<title>PressF1 - New Zealand's PC World self-help forum</title>
<style type="text/css">
PRE {
font-size : 9pt;
}
A {
font-weight : bold;
text-decoration : underline;
}
</style>
</head>

What you are seeing is some gabble between the server and you
it basicly is part of that process of
"hello server, i'm IE webbrowser, running on a doze box, can i have a file please?'
"hello webbrowser, i'm a server (the bit you shouldn't be seeing)"

Hey you really done well to get that displayed on top of a webpage!

Im just installing this cool update now, to see how much damage i can do to vanessa, my own win98 box

Chris Wilson
23-09-2002, 04:50 PM
Well apart from taking over my file associations, adding lots of unwanted icons to the desktop, and probably more to come that i haven't noticed yet SP1 for 98, didn't seem to do any real damage.

All pages are normal, in any browser things are just as they were.
perhaps you got a mucked up file in the download somewhere?

I wonder what options you have to go back and have a second try?

Iain
23-09-2002, 05:27 PM
Chris

I went back to M$ Download and re-downloaded the options. I ticked all boxes not associated with Media Player, Outlook or other languages and re-downloaded. No change. As I said earlier, a look on bulletin boards on sites such as ZDNet only found discussions about security and no mention of this problem. Others also commented about no obvious changes (BTW there is an option under "advanced" to stop it taking over the file associations).

I guess I was kind of hoping someone could tell me of a check box to change. I can just go back to IE 6 or sideways, but I am still stumped about why I get this problem.

Thanks IAIN