PDA

View Full Version : Spellcheck Word 97



willbry
21-08-2002, 09:16 PM
Can anyone help me resolve a difficulty . I cannot add unusual words to the dictionary as the option is greyed out. I have checked my custom setting to English (N.Z) but the problem lies in attempting to set and maintain the setting of the language from the drop down Tools menu. When I set it also to English (NZ) the spell check will work for one new entry only then greys out again . A check shows that the language has reverted to English (USA). This happens persistently despite re-setting to English (N.Z).How can I keep it stable at my chosen setting of English(NZ).?Would it pay me to give in and set them both to English (USA) as it seems as if the programme will only work with English (USA)

Antonia
21-08-2002, 11:39 PM
Hi Willbry,

Have you tried the Word Help Index ?
It gives lots of information under "Dictionaries".

Good Luck, Antonia

willbry
22-08-2002, 05:57 PM
Thanks Antonia. Will do so and see what it come up with.
Willbry

parry
22-08-2002, 06:54 PM
Hi Willbry, if you cant add words then its probably a corrupted custom.dic file. Follow these steps ...

1. Open Windows Explorer and navigate to C:\Windows\Application Data\Microsoft\Proof
2. Copy the file Custom.dic to another folder or rename the file Custom.bak (you can disregard this and steps 7+ if you dont want to save words youve already added to the dictionary. Just delete the file instead)
3. Open Word and select Tools-Options-Spelling & Grammar then click the Dictionaries button
4. Select the Custom.dic from the dictionary list then click remove and OK to the warning message
5. Select New then enter Custom.dic as the name and select Save. You can also set your language option.
6. Select OK x 2 to get back to Word

Now do a check by typing an unusual word to see you can add it ok. If successful then do the following to retain words already added….

7. Open the original custom.dic (the one you moved or changed to ext bak) and select the words and CTRl-C to copy. This is just a text file so use Notepad to open.
8. Navigate to C:\Windows\Application Data\Microsoft\Proof and open your new Custom.dic file and paste the words in.
9 Add another custom word to make sure the added words didn’t stuff up anything and you can still add words.
10. Delete the old custom.dic file

Cheers
Parry

antmannz
22-08-2002, 06:59 PM
Also, make sure Start > Settings > Control Panel > Regional Settings are set to English (New Zealand).

Antonia
22-08-2002, 08:36 PM
Hi again,

Antmannz suggestions may have worked for you already.

I had a search on Google to-day and came up with the following:

Background
With Microsoft Word 97 for Windows, you may spell and grammar check in English and a variety of languages. You must select the foreign language dictionary desired before you can spell check with any languages other than English (United States). The procedure to follow is:
1. Select the text to be spell checked.
2. If foreign language spell checking is desired, select the foreign language dictionary to use.
3. Run the spell-checker.


1. On the Tools menu, point to Language and select
Set Language from the pop-up menu; the dialog box to the right appears.

2. Use the scroll bar to find the language you wish to use.

3. Select the desired language from the list by clicking once on it to highlight it.
__________________________________________________ ________
(You knew all that, but it is the next bit you are interested in as you want English NZ to be the default language for all your work)

__________________________________________________ ________
 If you are using your PERSONAL COMPUTER and want to consistently use the foreign language dictionary, click DEFAULT.
 Click YES to confirm the change in default dictionaries.
3. Click OK.


I must add that this did not work for me, but I think it is because my Primary Network Logon is "Client for Microsoft Networks" (Settings>Control Panel>Network)
This may give the impression mine is not just a personal computer.
So I think it should just be the Windows Logon.

I think Antmanz is correct in saying that the Regional language setting must also be English Nz.

Anyway I will be interested to hear whether and how you solved the problem.

Bye for now, Antonia

Antonia
23-08-2002, 10:15 PM
I think this is the best solution so far. I found it on http://proofing.com/support/default.htm

Close and reopen Word. (If open) close Outlook as well.
Create a new document by choosing New in the File menu or pressing Ctrl + N keys.

Type: Do me a favour (or whatever).

Press Ctrl + A to select the text.

Open the Language dialog box and select the language
Press OK

Choose Save As from the File menu, or press Ctrl + S.

In the "Save as type": drop-down list, choose "Document Template" .
Type in a descriptive file name for the new template. Then press the save button to save your new template.

Close and reopen the document. Delete the text and save with changes.
From now on you can go File open and use your new template to create documents in your chosen language.

It works perfectly for English UK, which is my choice, as our NZ spelling is based on that anyway. Using this I can add words to the dictionary that are specifically NZ.

Using the English New Zealand setting does not allow adding words (greyed out) on our PC, but that could be because our regional setting is English British.

cheers, Antonia

willbry
24-08-2002, 06:30 PM
Hello Parry, Antimannz and Antonia
I'm very grateful for your help and suggestions. The problem has been resolved. My Regional Setting was English (USA) which didn't match my Language and Dictionary settings. Nonetheless have printed everything. offered for possible future use.
Again thanks to you all
Willbry