PDA

View Full Version : Restricting/Denying access to drive/partition in XP



Mike
12-08-2002, 10:51 AM
Scenario is we've got 3 partitions - C: = 10gb OS partition, D: = 25gb Personal partition, E: = 5gb Company partition.

Now we want to deny access to the company partition from the Personal user account, and deny access to the personal partition from the Company user account. Both accounts however can have access to C: for now, but might loose access to C: later and have only the administrator have access to that partition.

Any ideas how to do it? I thought it'd have been somewhere in the XP Security policies or Computer Management areas, but we can't find anywhere in there to do it - we can deny access to CD ROM and FDD, but not to HDD as far as we can find.

I know it can be done, as I've seen it in action (although that was in Win 2000 rather than XP), but can't figure out how to do it :)

Mike.

BIFF
12-08-2002, 07:25 PM
Before beginning, you Must have XP Pro to do this. Home edition does not support NTFS Permissions.

Right click My Computer and click Manage.
Go into the Local Users and Groups container.
Make sure the people you want to keep out are in the 'Users' group, not the 'Administrators' group. Make sure the account you are using is in the 'Administrators' group.
Go into the Disk Management container, check the partition you want to protect is of the type NTFS, not FAT. In this example I will use the drive E:
If it is fat, open a command prompt and type the following, or else skip ahead if already NTFS:

convert E: /FS:NTFS

Once you reboot the computer will have converted the partion to NTFS. Go into Tools->folder options, and click the View tab. Make sure Simple File sharing is not enabled. You will now have a Security Tab available on the properties of the Drive, and Folders and Files on that drive.
Deny the users you want to keep out by adding the 'Users' group and setting it to deny Read, Write, List Contents, Execute etc. Don't remove your own account or the SYSTEM account otherwise you may have problems.

I'm sorry this is so brief, but to do it justice would require pages of explaination.

Mike
12-08-2002, 08:03 PM
BIFF, It seems that this might just work! I had looked in all the right places - it was just that "simple file sharing" setting that I didn't know about. Now to get it tested out - will see how things go (its not on this system, so I probably won't know until tomorrow, but I don't see why it won't work :))

Thanks heaps :D

Mike.