PDA

View Full Version : MOHAA



cmlo
10-08-2002, 11:27 AM
After I installed MOHAA and tried to run it, this msg pop up =


Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...WARNING: missing Glide installation, assuming no 3Dfx available
...shutting down QGL
GLW_StartOpenGL() - could not load OpenGL subsystem


CAn someone help? I tried various ways to fix it but don't seem to work.

Thanks!

John Grieve
10-08-2002, 12:08 PM
If you are running XP then go to the NVidia site and download the latest Detonator drivers that support XP. XP has no support for OpenGL built in so you need drivers that support openGL specifically.

Before you do that however have a look at this and try the DVA=0 tweak if indeed you have it enabled.

This error indicates a trouble initializing your 3D graphics card. The first thing to check would be to ensure that you meet the games requirements for at least a 16 MB video card with support for OpenGL. To find out what type of video card you have: Go to Start and select Run and type dxdiag and press Ok. Along the top of the tool click on the tab that says Display. On the left side near the top it will state the name. Also note the Aprox. Total Memory a couple lines below the name.
Next, ensure that you have the latest drivers installed for your card. You will want to check the card manufacturers web site for any updates and follow any directions that they provide.

Also, OpenGL does not work with multiple monitor setups. If you have a dual-display you will need to disable the secondary monitor.

Follow these steps to do so:
- Right click on the Desktop background and select 'Properties' - Click on the 'Settings' tab
- Click on the monitor that is labeled with a number '2'
- Uncheck the box that says "Extend my Windows desktop onto this monitor".
- Click 'Apply' and 'Ok'. The game should now run properly.


If you are still receiving this error once both of these things are met check the following: Go to Start > Run and in the run box type "win.ini" without the quotes and click the OK button. The Win.ini window should come to the foreground, scroll through the list of items until you come to [DrawDib]. Look for a line under [DrawDib] that says DVA=0 and remove it. Click File, then Save and close the Sysedit program. Try the game at this point.

If you do not see the DVA=0 line under the [DrawDib] section, then this is not the cause of your problem. DVA stands for Direct Video Access, and is commonly set to 0 to fix issues with older games or video problems with old software. Unfortunately it causes the game to not recognize OpenGL support on your system as well. The only way to fix this is to remove that line. This should not affect anything on your system.

This is from http://www.geocities.com/lionshonorsquad/mohaa.htm