PDA

View Full Version : svchost - playing up as usual



Graham Petrie
31-07-2002, 01:36 PM
My flatmates pc is connected through mine to the internet over a crossover network using TCP/IP protocol.

Everything works fine, and I have finally found a firewall which works with windows XP ICS (both pc's have windows XP Pro). The firewall is Sygate Personal Firewall v5 found on this months PC World CD. (Previous versions of Sygate did not supprot WinXP ICS).

The problem is, everytime my flatmet starts up his pc, it tries to make a dial-up connection.

After installing sygate on his PC it told uys that the outgoing connection is a UDP connection to IP address 255.255.255.255 on ports 137 and 138 from local porst 37 and 138. The culprit is svchost (Generic Host Process) I kind of understand what svchost is and oes, but why is it trying to connect every time??

Any ideas on how to fix it, or what is causing it? The problem still exists with all services and startup apps disabled in msconfig.

No trojans or the like can be found.

Has always happened, but I am finally sick of the damn thing.

Thanks everyone.

G P

boom23
31-07-2002, 01:46 PM
I'll take a while guess here. some of the apps are probably trying to access the internet on either you pc or the other pc. Check all the apps which have auto start feature and auto update feature. You firewall could be trying to access the internet also if it's got auto update.

Graham Petrie
31-07-2002, 07:12 PM
boom23 - please read the question. All startup apps are disabled. The problem is with a windows operating system service svchost aka Win32 Generic Host Process.

see the folllowing KB article for more info Q314056 (http://support.microsoft.com/default.aspx?scid=kb;en-us;Q314056)

Anyone else??

G P

Graham Petrie
31-07-2002, 07:14 PM
The source ports should be 137 and 138 not 37 and 138.

John Grieve
31-07-2002, 07:49 PM
Ports 137, 138 and 139 are NetBios. Unless you need it you can disable it as follows (at least on XP): go into Network Conections, right click your connection, select properties, highlight Internet (tcp/ip) and hit properties. Then click on Advanced, select the Wins tab, and select Disable NetBios over TCP/IP and hit apply. It should no longer be listening.

Graham Petrie
31-07-2002, 07:53 PM
Ahaaa! What exactly does the NetBIOS do? I know there is a service relating to NetBIOS which utilises svchost. I will disable it and see.

G P

Graham Petrie
31-07-2002, 08:02 PM
a Google search indicates I probaby need netbios for file and print sharing. Any ideas why it is initiating a dialup session and how to stop it without stopping file and print sharing?

G P

Graham Petrie
01-08-2002, 03:46 PM
<bump> John, can you give me any more info?

G P

tweak\'e
01-08-2002, 04:03 PM
if i remember correctly netbios over tcp/ip is turned off by default in XP.

unless you really have to, use another protocol for file&print sharing.

Graham Petrie
01-08-2002, 04:09 PM
I am not that conversant with networking - something I am working to remedy. How would you suggest i set things up. File sharing and messaging between the PC's is essential as is sharing a printer and the web connection.

Thanks tweak'e

John Grieve
01-08-2002, 05:33 PM
Although this link is ostensibly about cable it deals with the facts about Netbios well. Hope it helps.

http://cable-dsl.home.att.net/netbios.htm

tech_mister
02-08-2002, 12:35 AM
I don,t think you need you need NetBIOS enabled because both pc,s
are running XP.
You can disable dialup on demand in the dialup connections advanced
properties .