PDA

View Full Version : Disappearing CD-Rom Drives?!



scottw
29-07-2002, 09:34 PM
My machine has come up with a new game. Its called I can't see my cd writer or dvd drive. The short cuts when pressed say "Error not found" and have a question mark on them. Best of all it does this randomly. The devices are not listed in device manager nor do they appear in the control panel. They do not show any signs of power in this mode. However when rebooting they spark into life but sometimes still not to be re-found by the PC. Any ideas?. Running win XP home edition.

godfather
29-07-2002, 09:39 PM
> They do not show any signs of power in this mode.

Assume you mean they dont open or close?

In that case they haven't got any power? look at all your connectors inside first....They will dissapear without supply.

loser
29-07-2002, 11:51 PM
my flatmate has that problem with his machine.... a cdrom and cdrw drive, running win me. we haven't been able to find a solution. the best we have found is to reboot a few times until they appear.
bizzare....
I'd be interested if you find a solution

bmason
30-07-2002, 12:11 AM
Perhaps your power supply is having trouble supplying enough power to the drives.

What rating is your power supply, and have you added any new hardware recently (hard drive, cdrom, graphics card, even ram) ?


I've just finished fixing a system that did similar (but worse) because its PSU had cooked after its fan stopped working.

scottw
31-07-2002, 07:32 PM
Hi

Yes I've recently added a 40gig HDD and a Leadtek G4 card (not both at the same time). Didn't notice the problem till the card went in though.

PS is 300W

bmason
31-07-2002, 08:59 PM
300w should be fine unless its a particularly crappy one.

IIRC the real GF4s (not GF4MX) use quite a bit of power.

Try removing any non-essential hardware and see it still happens.

eg modem, sound, one of the cd/dvd drives, going back to your old graphics card, etc.