PDA

View Full Version : No Alt F4 shortcut in XP Pro



tjc1
11-07-2002, 09:02 PM
My boss has bought me a nice new computer with a big screen, running XP Pro, but it is driving me crazy. Sometimes the good old Alt F4 key combination closes Word, and other days it has no effect. Sometimes Alt F drops the file menu down, other days it inserts a footnote.
In Internet Explorer Alt F4 either closes the program, or else drops down the URL box list.

godfather
11-07-2002, 09:12 PM
Thats because you are confusing the "Windows" key (between Ctrl and Alt) with the Alt key.

Alt+F4 closes the program, Win + F4 drops down the box etc.

If you are not confusing the keys, you may have a fault in the keyboard, but if you are a touch typist I would bet you are hitting that new"Win" key on the keyboard....

Mike
11-07-2002, 09:18 PM
> My boss has bought me a nice new computer with a big
> screen, running XP Pro, but it is driving me crazy.
> Sometimes the good old Alt F4 key combination closes
> Word, and other days it has no effect. Sometimes Alt
> F drops the file menu down, other days it inserts a
> footnote.
> In Internet Explorer Alt F4 either closes the
> program, or else drops down the URL box list.

tjc,

it sounds like you've got some pretty big problems with your computer set-up. Before I get onto the good old "you need to format your computer and reinstall everything" (which might actually be what you need to do), try checking out some things.

Check what you've got your language set up as:

Start > Control Panel.
Click on Regional and Language Settings.
In the new window, click on the Languages tab, and then click on the Details... button
A new window should open up called "Text Services and Input Languages". Check that the Default input language is set to "English (New Zealand) - US". This tells Windows XP that your desired language is NZ English, but that the keyboard layout is the US version.
Now under Installed Services check again that you've got "English (New Zealand)" at the top of the list, next to a box with EN in it, and some settings underneath; underneath this should be a little icon of a keyboard, with "US" underneath that.

Now if all this is set correctly, then your keyboard should be set up correctly to handle all keyboard shortcuts correctly. If this is all set correctly, then you could have something else causing the problems, for example, in Word there is a setting telling it to recognise WordPerfect commands, and so sometimes when you try a shortcut it may be thinking its a WordPerfect command. You'll need to change the Word Options (I think under the tools menu?) to tell it not to use WordPerfect commands.

The only other thing I can think of that could be causing you problems (and the least likely) is that you may have another program running in the background that is set up to do certain things when keyboard shortcuts are used - overriding the Windows default settings.

Now I know that probably none of these will work for you, but its good to give them a try before wiping the computer and starting from scratch (which should always be a last resort.

HTH

Mike.

Mike
11-07-2002, 09:20 PM
> Thats because you are confusing the "Windows" key
> (between Ctrl and Alt) with the Alt key.
>
> Alt+F4 closes the program, Win + F4 drops down the
> box etc.
>
> If you are not confusing the keys, you may have a
> fault in the keyboard, but if you are a touch typist
> I would bet you are hitting that new"Win" key on the
> keyboard....

LOL or that too :) I was thinking a bit too far down the track I feel :D

Mike.

tjc1
11-07-2002, 09:28 PM
Well, you were nearly onto it Godfather!!
I have just done a bit more checking after reading an unrelated post about the left and right Alt keys doing different things.
I am left handed and hit the right Alt key then the other key with my left hand. But when I use the left Alt key plus F4 or F etc everything works fine !
That would be why everything worked fine for the techie when he dropped in yesterday while I was out.
Now the hunt is on to reassign the righthand Alt key to its proper purpose.
Many thanks.

godfather
11-07-2002, 09:41 PM
Check your settings for the keyboard, if you have it set for europe there is a difference but shouldnt be for US.

If set for europe I would have thought the $ key would be remapped?

Look in start-control panel-regional and language-settings-language-details.

Look in the panel there for keyboard, it should say US.

You cannot set it from the keyboard option under control panel apparently

tjc1
11-07-2002, 09:52 PM
Thank you. All fixed.
It was set on US International.