PDA

View Full Version : I can traceroute but can't ping?!



25-04-2002, 12:37 PM
Hi,
I've got several computers connected via a local switch, with one as my DSL gateway, and everything is working fine. (running win98 and linux)

However I recently tried to set up a LAN game over a couple of them, only to fail as they could not see each other.

Indeed I verified this by dropping down to a DOS prompt, where I found that the two computers couldn't ping each other. (The two I'm looking at are set up with the gateway computer having an internal address of 192.168.0.1 and the other being 192.168.0.5)

After a bit of examination, it looks like everythings fine except for tcp/ip _between_ the computers.

ie. NETBeui networking works fine, TCP/IP works fine from the .0.5 computer, as long as I'm going further afield than the next hop. (i.e. I can ping external addresses no problem)

I can even traceroute from the .0.5 computer to an external address and see that the first computer on it's trip is the gateway 192.168.0.1 before it heads further afield.

But if I try to just ping the local computer it times out.

(Firewalls off; same subnet mask; either directly connected or via a switch)

Any ideas?

25-04-2002, 03:14 PM
In my experience, Win98 networking can get knotted - especially after changing settings. If I can't ping one machine to another - the most basic test(!) I delete the network card and re-install. Invariably works!

25-04-2002, 03:49 PM
Try and keep all your systems organised. It's more time consuming but it's better practise and you can pin point exactly which machines are having the faults.

Using 192.168.x.x/255.255.255.0 you can set up your gateway to 192.168.x.1 and then your host/ICS computer to the next then all your clients can get 192.168.x.3-254.

All computers will need TCP/IP enabled NETBeui isn't neccessary. IPX/SPX is sometimes required for older games but TCP/IP is the main one to use. All computers will need Client for MS Network apart from the Linux machines which use something else.

There's a file called LMHosts where you are suppose to add all the IPs of the computers on the network this will allow all the computers to be seen in the network neighbourhood another alternative is a setting in the network properties called LMBrowser and enabling this on all machines gives them the ability to see each other.

Firewalls can get in the way and only setting them up correctly would help.

Pinging your localhost IP 127.0.0.1 to see if that works. Then pinging the localhost IP of the network card whatever that is to test if that works. If it doesn't then there's a fault related with the network card.

Try pinging all the other computers and noting the ones that didn't respond. You'll need to check their configuration to make sure they are set up correctly.

Also important to have the subnet the same on your network or you'll find that none of the machines will respond to each other. 255.255.255.0 can be used for the subnet mask.

25-04-2002, 06:42 PM
I just deleted and re-added the cards and services - no change I'm afraid.

26-04-2002, 02:47 PM
Will your gateway machine work as a gateway with IP address other than xxx.yyy.zzz.1? .1 is typically allocated to a router. And you can't ping a router. You can telnet into a router, but it doen't respond to pinging. It's supposed to be transparent.

I'm sure that Microsoft have 'improved' the standard conventions, but give it a try if nothing else works.

28-04-2002, 03:02 PM
Well, after checking everything again, my IP address set-up was fine (main machine has both an external IP address for my cable connection and the 192.168 address for the internal connection), but after comparing the non-pingable 0.5 computer to another one on the network that would work, I finally spotted the problem - when I looked at it with winipcfg, I spotted the PPP adapter for some reason also had the IP address 192.168.0.5 (they're usually listed as 0.0.0.0 until you dial up).

As this computer doesn't actually have a modem, I simply removed the dial-up adapter from the network neighbourhood, and everything's working fine.

thanks for your help everyone.