PDA

View Full Version : Registry backups



07-04-2002, 02:15 PM
I use win98 se, and have in the recent past wanted to restore the registry to that of the previous day.
So I started the computer by holding down the control key. On the ensuing startup menu I selected Safe Mode command prompt only.
I then typed scanreg/restore and pressed enter.
I then had the options of 5 backup registry files ranging from 12/08/01 to 12/04/01.

I thought the registry was automatically backed up every day and I am very surprised at these (albeit old) options. Of course I have added a lot of software since 12/08/01 and am reluctant to restore.

I have checked my system settings against the atomic clock and they are correct.
Can anyone enlighten me about the windows registry backups and the frequency there-of.
Are registry settings encompassed in the files system.dat and user.dat?
Cheers
Cam

07-04-2002, 02:50 PM
Hi Cam

Do you leave your computer running 24/7? I have noticed on my W98 computer Registry is only backed up from a cold start (hard boot) so even if you add programs that require a reboot you will not get a fresh registry backup.

If you want to force a registry backup after installing new software, either shutdown & switch off then restart or use the 'back up reg' function. I prefer the former as it lets me see if the new installation is going to cause boot problems.

Cheers

Billy 8-{)

07-04-2002, 04:02 PM
Billy T
No I never leave the machine on overnight, it's always a cold boot every day - the dates of these registry backups are a mystery.
Thanks anyway
Cam

07-04-2002, 04:02 PM
I should also check your scanreg.ini file in c:\windows.
This is the file that tells scanregw.exe what to do, where to store the backup files, which files to back up, how many days etc.

It is a self explanatory text file which you can edit with Notepad.

07-04-2002, 05:06 PM
It's possible that your Scanreg has disappeared from your Startup menu.

Go to Start, Run, type in msconfig and click OK.

Now click on the Startup tab and look through the list presented. Near the top should be ScanRegistry and it should have a tick beside it.

If it hasn't that is probably the answer to your problem.