PDA

View Full Version : Games on XP Pro (NTFS)



05-04-2002, 02:10 PM
I am having trouble running The Sims and Half Life on a limited account in XP Pro. I have changed the file system to NTFS for security reasons but fear that those games have decieded they don't like NTFS and have gone on strike.

Do I have to revert back to FAT32 (erm, is that possible actually??)

Change ltd account to admin acccount? (eek - it's my little sister I dread to think the damage she'll do!)

Please help!

05-04-2002, 02:48 PM
If you know which files needs access full access for those games to run you'll need to set those permissions.

I've got Half Life to run on WinXP Pro (NTFS). Haven't got The Sims so I don't know about that one.

05-04-2002, 04:29 PM
I'd suggest it would be the permissions you've set that is causing the games not to run properly. NTFS is just a file system, it won't cause one program to run and another not to. So you may need to figure out which permissions to set for the games to work properly.

Mike

PS you cannot revert back to FAT32 from NTFS without formatting your drive.

05-04-2002, 06:09 PM
Mike,
It is possable to convert XP NTFS back to FAT32 with either Partition Manager 7.0 or Partition Magic.

05-04-2002, 07:57 PM
If the NTFS permissions are already open the problem could be caused by registry permissions (I know halflife has a hissy fit over this).

To loosen the registry permissions try applying the Compatible Workstation security template. Follow these instructions courtesy of 'anon' (from press F1 archives; -copied and pasted...)

load mmc: Start->Run->mmc
Add a snap in
Add the 'Security configuration and Anaysis' snap in.
OK back to the Main MMC window.
Highlight the snap-in
Right click, and click 'Open database'
Make a new database, you will then be prompted to import a template. Browse to Winnt\security\templates and open the compatws.inf template. You will then be returned to the main MMC screen. Right click the snap-in, and click 'configure the computer'. The 'Compatible Workstation' template settings will then be applied. Log out and back in, try your software.

06-04-2002, 08:29 PM
Regarding permissions on XP - try unchecking 'Use Simple File Sharing' (in explorer under Tools/Folder Options/ View Tab).

This gave me a lot of grief when trying to use IIS, until I unchecked it, then things suddenly worked.

07-04-2002, 07:24 PM
I'm running XP Pro, and both Half-Life and The Sims run fine for me. Make sure you have installed all of the latest updates/patches for the games and Windows. I'm playing these under an admin account...I don't know if this matters or not, though.

07-04-2002, 07:24 PM
I'm running XP Pro, and both Half-Life and The Sims run fine for me. Make sure you have installed all of the latest updates/patches for the games and Windows. I'm playing these under an admin account...I don't know if this matters or not, though.