PDA

View Full Version : Itex ADSL card with Linux



30-03-2002, 02:51 PM
I've now spent a week trying to get a Dynalink AHL-110 to work with Linux. I've followed the instructions in http://www.ahs- png.org/lintech/linux_hints_tips/ADSL/ but have struck a problem.

When I 'insmod itex1577-2.4.2.o' the driver correctly finds the card and it's settings but then segmentation faults. The output of which is at the end of this message. The fault happens after retrieving the MAC address but before reporting the chip number.

If I remove the card from the machine insmod doesn't segmentation fault (it doesn't load of course).

The only thing I can find that hints at a possible problem is that depmod says there are unresolved symbols in itex1577-2.4.2.o. Or is this OK as others seem to get this as well.

The machine is an old Pentium 166, but presumeably this isn't a problem.

I've emailed Itex about this and got the latest drivers off them but still can't solve it. I've tried so many different kernel configurations that I'm sure that's not it.

Any help, hints, suggestions greatly appreciated. Please, I'm getting desperate.

itexadsl: version= 2.2.7.ITEXPC86.0001 , built date= Wed Nov 21 13:13:09 PST 2001
itexadsl: card# 0, ix=0x0, bus=0x0, fn=0x98, ven=0x1471, dev=0x188
itexadsl: total 1 card(s) found.
itexadsl: irq=0xc, ioaddr=0x6000, membase=0xe4000000
itexadsl: card #0 - MAC: 00:90:96:22:69:d5 from eeprom.
Unable to handle kernel paging request at virtual address c28fd000

31-03-2002, 01:29 PM
You could try adding insmod itex1577-2.4.2 to your /etc/rc.d/local and rebooting. This will try and load the module on startup and may solve your problem.

After the module is loaded I think it's safe to remove insmod itex* from your /etc/rc.d/local file.

31-03-2002, 05:23 PM
No go with rc.local, exactly the same result.

Thanks for the suggestion anyway.

02-04-2002, 01:25 PM
I suspect that the board has a default 'membase' which is beyond your physical memory.

An address of e4000000 is *way* up --- nearly 4GB.

Try giving a 'membase=0xsomething_in_your_memory_space' argument to the insmod command.

This is based on my extensive ignorance of ADSL. I have had a few segmentation errors in my time though. It means that a piece of code is trying to access memory which is either non-existent, or not allowed to the user.

The other idea I have just had --- to use insmod, you need to be root, that is, have privilege. That could be your problem. The memory alocationb would be illegal for a 'user'. Loading from rc.local would cure that though (it is run at each boot, while the system is in single-user [root] mode).

06-04-2002, 11:02 PM
Bugger, it doesn't understand membase. For:

insmod -f itex1577-2.4.2.o membase=0x0e400000

I get:

itex1577-2.4.2.o: invalid parameter: parm_membase

Nevermind. Thanks for the suggestion anyway.

07-04-2002, 12:44 AM
Just to prove I don't really know too much about building a linux kernel... /sbin/insmod has not been recompiled with my kernel rebuilds.

Is this correct? Should it have been? It could certainly explain some problems if it's supposed to be.

cyber
12-02-2005, 09:53 PM
I have ADSL modem Alcatel SpeedTouchPC (iTex i90388)
I use module itex1422-2.4.2-2.o and Linux RedHat7.1 (kernel 2.4.2-2)
module correct install, pppoe starting and connecting, internet work....
but there is on display system message:
sar: 10ccccd, mac xxxxxxxx (this packet not ours!)

this message are dont effect the internet speed but it makes us some troubles while working....

Prescott
12-02-2005, 09:58 PM
cyber, have you noticed the date from the post you are replying to?

cyber
13-02-2005, 02:48 AM
I see...
This modem work in Windows...
Im ready use Linux and appear this problem.

Prescott
13-02-2005, 09:19 AM
sorry but im not following, are you having a problem with your modem when using linux?

Murray P
13-02-2005, 11:22 AM
Is your modem amongst this lot at Alcatel (http://www.speedtouch.com/supuser.htm)?

cyber
13-02-2005, 08:01 PM
yes
Alcatel SpeedTouch PC

cyber
13-02-2005, 08:19 PM
Alcatel support - fu@%ing support in the world!