PDA

View Full Version : Network Card Lockout



27-03-2002, 06:25 PM
This is a rerun of my problem posted last year as my lockouts continue. In the interim I have bought a new NIC (#2) & checked everything I can think of (which isn't too much as I'm not clued on network matters)

My ethernet connection seems to go to sleep after a variable period from minutes to several hours and I have to reboot to get it going again.

System is a P166 with 256MB RAM, A-Trend ATC-5030 motherboard with Intel 430TX chipset. OS is Win98 first edition.

The ethernet connection is via a new D-Link DFE-530TX 10/100 PCI network card. It auto installs on IRQ11 (shared with 'IRQ for PCI steering') and I can't shift it to IRQ5 which is free because the device manager/resources feature tells me 'this resource setting cannot be modified'

Internet access is Jetstream via a Nokia router shared via a hub to another computer. Normal service is still available from my other PC during lockouts so the hub-modem combination are functioning OK. The hub ports used are also OK.

I think I might have narrowed the cause down to Outlook 2000 but in brief, if I boot up I can access the internet ok but sometimes when I try to download email the connection fails and if I try to go back to the net I find that I no longer have access, i.e there is no communication between my network card and the router.

While all this is going on, I still have full access via the other computer so the hub/router/jetstream connection is ok.

Rebooting will usually restore service but sometimes I have to reboot twice to get my email going again.

I have noticed that even though I have closed Outlook before rebooting, sometimes the shutdown hangs and CTRL/ALT/DEL tells me that 'Outlook is not responding' End task allows the reboot to continue.

My gut feeling is that Outlook is the problem but how do I find out where the blockage occurs? I'd like to actually trace what process is failing. It doesn't seem likely that it is a setting in Outlook or for the NIC as when it works, it is going fine. It appears to be a conflict of some sort that blocks communication or locks the NIC.

I know I had heaps of help and advice last time but I guess I have to impose one more time.

Any help or advice will be most gratefully received.

Jim

27-03-2002, 11:14 PM
Hi Jim

There are few things more frustrating than Network Issues.

My suggestion would be to check your NIC settings regarding wake-up and power saving options.

Right click the Network Neighbourhood desktop icon and click properties.

Then select your NIC from the list and again click properties.

Click the advanced tab and check that any power saving is disabled and maybe enable any wake-up settings.

You may have already been down this path, if so I apologise.

Good luck mate

J.

27-03-2002, 11:14 PM
couple of thoughts on this one. You may have heard these already but anyway

When the computer drops off the network is the 'link' light on the rear of the nic card still on?

Have you tired setting the nics to a set speed ie 10 or 100megs instead of 'autosense'

and lastly have you tried swapping the patch leads about to see if fault swaps to another machine.

==Orac==

28-03-2002, 11:46 AM
Thanks Guys

Responding to suggestions from
Jester:
There are no power savings options that I can see unless I should also be looking in Bios; 'Magic Packet WakeUp' is enabled by default (whatever MPW is!); and 'WOL Type' is set to pulse (the only other option is 'button'). I can't see any other relevant-looking options there and everything is set to the install defaults. Being the third NIC in this machine I think I can rule out hardware as the cause, though I would love to get the NIC onto IRQ5 to see if that helps. I also tried reserving memory for IRQ11 via the 386ENH section of System Ini but that didn't help.

Responding to Orac:
I am sure I have changed the patch lead but I'll try another; I hadn't thought to check the link light status (D'oh) but I'll do that next time it locks up; Speed is set to autosense but I have a choice of 10 Base T 'Twisted Pair' or 'Full Duplex'. Which option should I select?

Incidentally, the NIC appears three times in network properties, once as the card itself then twice more for TCP/IP and NetBui. I don't know what NetBui is doing but the other networked computer runs W2K and it was all set up by a computer company.

It seems strange that the system will work perfectly well when going and keep that up all day sometimes, then another day it will have me climbing the wall by locking out every few minutes

Thaks for the suggestions

Jim

28-03-2002, 06:21 PM
In desperation, perhaps you should disable the 'Magic Packet Wakeup', and WOL. These are elements of the same thing (Wake On Lan allows, say a sytem adminstrator, upgraade software during the night, when no-one else is working. WOL lets the computer be turned on remotely, so it will receive the downloads.) The Magic Packet is a lot of repetitions of the MAC of the card in a particular machine. The MAC is the 48 bit unique number assigned to the NIC by its manufacturer.

If you installed the new card your self, there whould have been a cable to install from the NIC to a 3pin connector on the Motherboard. I can't see the lack (or presence) of that cable mattering --- but desperation drives. When the card recognises a Magic Packet for itself, it does a switch closeure on that cable -- which works like the 'power switch' on your ATX box. It is never completely off ... there is a little bit of current flowing into the NIC and any modem which might have a similar wakeup mode.

Otherwise, it's got me guessing ... obviously there is some strange software clash causing somthing which 'can never happen' to happen often.

Good luck ...

28-03-2002, 08:59 PM
Thanks Graham

I did install the NIC myself and didn't use the WOL cable.

I've now disabled magic packets but since there's no disable option for WOL I'll install the cable. What setting should I use, pulse or button?

I spent just about all afternoon searching the Net for Outlook 2000 bugs and the only one I could find related to a mapi32.dll issue. I found two such files on my system, one dated 98 and the other 99 so I renamed them per the instructions and Outlook automatically replaced them with one dated 2000. The correct file size is 128K (which both originals and replacements were) and it didn't help as far as I can tell so I guess the ones I had originally were ok.

Is there any way to force the NIC off the shared IRQ? I can't see anything in Bios that would let me reserve the IRQ except perhaps if I uninstall the NIC, reserve IRQ 11 for 'Legacy Isa', let the IRQ for PCI Steering' find a new IRQ then re-enable IRQ11 for PCI use, reinstall the NIC and hope that it gets exclusive use of that IRQ.

Your ciomments would be appreciated.

Thanks

Jim

30-03-2002, 01:31 PM
One problem I had was that I had my network card going to sleep after a period of inactivity. This had to do with the Power Saving settings. I just disabled the Sleep and have had no problems since.