View Full Version : Win10 default audio hardware issue

30-01-2018, 04:51 PM
How do I stop Win10 changing the default audio device

Its a PC used for a projector
Audio needs to go through the 3.5mm audio out jack
When the projector is turned on, the default audio output ALLWAYS changes to HDMI audio . Allways, even if disabled(10 just re-enables it)
So have to go into sound properties & change the default back

Any way to stop this ?
Ive found a way to enable audio through more than one device , but havnt tried that on this system yet .
Would prefer a fix than a workaroud

30-01-2018, 05:18 PM
Don't know if this will work or not. Our Media center has HDMI output to the TV ( crap speakers) , But better external speakers plugged into the 3.5 mm and it never changes, cant test this, so this is only a guess.

Try going into the Device manager, OR the speaker setting (Via control panel) locate the HDMI Audio under sounds,Video and Game Controllers( For device manager), and right click - disable it. ( disable the right one, you'll soon figure out if it incorrect) ;)

In theory, if its disabled it shouldn't work and unable to change. :2cents:

30-01-2018, 08:43 PM
Might not be an easy way, Whenever windows detects a new audio device plugged in it seems to assume that's your new default, especially if it doesn't detect anything on the normal default.
It also seems to really like the HDMI option, I had the reverse issue but setting HDMI as default works when it's always connected.

Does the projector have an Audio out and would letting the audio pass through it be an option? That's how I deal with my media PC, I connect the speakers to the headphone output of the TV and let the HDMI output take over the PC.

There is some suggestion on various forums that the audio driver can be the culprit if it's not jack sensing properly, some have had success with older or newer drivers.

31-01-2018, 03:10 PM
I found that with sons....it kept making his TV default speaker.
I disabled the TV in the end.

Now he has an actual monitor, so can't comment on whether it would have lasted or not.

01-02-2018, 08:57 AM
I tried disabling , but as soon as projector is turned back on , Win re-enables it & makes it the default.

A Win10 PC Im testing with does the exact opposite, keeps making the old analog audio the default :-) .
Seems the only way around it is to setup so audio comes out of both