PDA

View Full Version : Win 10 Pro Automatic Update



bk T
27-06-2017, 10:22 AM
I used Group Policy Editor to restrict Win10's automatic update. It used to work quite well before but of late, I noticed that Win 10's auto update still doing the auto update a few days ago.

That morning, when I turned ON my PC, it loads fine but after a minute or two, everything has come to a standstill - only the small circle spinning. Couldn't do anything, couldn't launch Firefox, nothing .

Somehow, I managed to use the task manager (?) to RESTART the machine and it took almost 20 min to do all those updating, configuring, thingy. Everything works OK after it has restarted.

The following is what I done from Gpedit:

Computer Configuration -> Administrative Templates -> Windows Components ->Windows Update

Double-clicked Configure automatic updates -> Enabled -> selected no. 2 -- Notify for Download and Automatic install.


Have I done something wrong here?

wainuitech
27-06-2017, 11:14 AM
Nope.

As posted on this site that explains several methods. http://www.askvg.com/fixing-windows-10-automatic-updates-install-problem/


Since Microsoft has completely replaced old Windows Update program with a new modern app in Windows 10, the Group Policy or Registry tweak to change Windows Update settings don't work immediately. Even after restarting your computer or executing gpupdate /force command, the changes are not applied in Windows Update window.

There may have already been updates on the way that had to finish.

I personally just use a couple of .bat files ;) they work fine. If windows tries to update it errors. Until I reactivate it again.

1101
27-06-2017, 12:29 PM
In the past, "notify only" wasnt.
Despite setting notify only , MS could still force through any updates they deemed urgent

Not sure if its still the case , but it wouldnt surprise me.
The best way is to disable the update service, then re-enable when convenient for you . can be done via a batch file .

Also, after major updates (ie a new 10 build version), your update settings might be reverted to default

mzee
29-06-2017, 08:24 PM
I always have auto Windows updates turned off, have done so for years. Very seldom have problems.

Chilling_Silence
06-07-2017, 06:35 PM
I just go in to Services and change "Windows Updates" to "Disabled", never starts up that way, seems fine on Win10.

autechre
07-07-2017, 10:56 AM
I just go in to Services and change "Windows Updates" to "Disabled", never starts up that way, seems fine on Win10.

This.

The only way to stop Windows Updates happening is to disable the Windows Update service. Set it to Automatic or Manual when you do actually want to do some updates and disable it again after its done.

1101
07-07-2017, 12:56 PM
I just go in to Services and change "Windows Updates" to "Disabled", never starts up that way, seems fine on Win10.

You should be able to setup 2 batch files (on the desktop), for on & off : bat file to turn update service on/off
That would be a bit easier for some.

Probably what WT was referring to :)

wainuitech
07-07-2017, 05:22 PM
You should be able to setup 2 batch files (on the desktop), for on & off : bat file to turn update service on/off
That would be a bit easier for some.

Probably what WT was referring to :) Yep, that's exactly what I do. I have them on a couple of computers that update only when I want them to ( media center for example).

As described simple as double click ( or right click run as admin) and updates stop, then same to get them going again.

8147