PDA

View Full Version : MS (mighty mouse) rampage



jupiter1
22-03-2017, 06:57 PM
Hi Team,
I have a Toshiba lap top C850/3005 running Windows 7 Pro 32 bit fully updated to 11am today (22/3/2017)

I have been using a MS wireless mouse for some time but about 2 weeks ago the mouse started taking control of me.
A single click frequently was double thus bringing a page in twice.
A single click function often needed 2 clicks.
The scroll wheel frequently transposed up for down and vice-versa.

I cleaned the red led and lens and replaced the mouse pad with a new one without effect.
I also put new batteries in these mice.
So I changed back to my old corded mouse after cleaning the lens.
I ran both mice in another laptop, an Asus A6Q VM without any failure.
The dammed mouse still frustrates my uses on the Toshiba.

I have run CCleaner, MS Essentials and Defrag.

Does anyone have an solution to this dammed rodent please.
Please do not tell me to upgrade to Win 10, I suspect this rat will jump ship.

wainuitech
22-03-2017, 07:39 PM
Have you tried starting the computer in safe mode to see if it still does it ?

Could also be faulty drivers - you may need to go into the device manager, uninstall the mouse reboot and let it reload new drivers ( or software if there is any)

jupiter1
23-03-2017, 08:00 AM
Have you tried starting the computer in safe mode to see if it still does it ?

Could also be faulty drivers - you may need to go into the device manager, uninstall the mouse reboot and let it reload new drivers ( or software if there is any)

The mouse was installed twice in the device manager for some reason.
Have deleted one.
Will wait and see if I need to delete other and re-install drivers as you advise.
I will keep you upto date.
Many thanks.

pctek
23-03-2017, 01:16 PM
I suspect this rat will jump ship.

LOL.....
I see it's sorted, but that was funny

Laggard
24-03-2017, 12:59 PM
I've given up on MS mice, they seem to have a limited lifespan. I've been using a Logitech mouse, seems good.

Had a clean out the other day found I had six dead MS rodents.

Speedy Gonzales
24-03-2017, 01:52 PM
Got that right these 2 wireless ms crapolas are ready to crap out.

As soon as the ones I brought on Ebay arrive (hopefully sometime this century). MS mice and keyboard meet the bin

jupiter1
26-03-2017, 10:42 AM
The mouse was installed twice in the device manager for some reason.
Have deleted one.
Will wait and see if I need to delete other and re-install drivers as you advise.
I will keep you upto date.
Many thanks.

Well, I have deleted both now, powered off for 30 secs and re-booted and then attached the mouse.
All "seems" to be working OK but the mouse driver has installed twice again !

However, all seems to be working OK so will reply again if there is any change.
Cheers to all.