PDA

View Full Version : Logitech HD Webcam c525



Pato
16-07-2016, 05:51 PM
This was working perfectly in Windows 7 but no luck with Windows 10. I have downloaded the recommended driver (lws280.exe) but won't connect.

Anyone else using this Webcam in Windows 10?.

apsattv
17-07-2016, 05:27 AM
Did you try another usb port?

Pato
17-07-2016, 10:36 AM
Did you try another usb port?No, but I will. Thanks. Are you using this Webcam.?

bevy121
17-07-2016, 01:10 PM
apparently people have had success just unplugging and plugging back in again after windows is running with this webcam - have you tried that?

KarameaDave
17-07-2016, 03:20 PM
Have you tried installing the driver in compatibility mode?

Pato
17-07-2016, 04:54 PM
I downloaded the recommended driver for win10 (lws280.exe) but got "No Webcam Detected". I then tried (lws280.exe) driver for win7 but that was not compatible.

I am not sure if I should uninstall the win7 driver.? If so, how is it done in win10.?

Pato
17-07-2016, 04:55 PM
Did you try another usb port?Yes. Tried another usb port.

Pato
17-07-2016, 05:02 PM
apparently people have had success just unplugging and plugging back in again after windows is running with this webcam - have you tried that?Tried that but never worked.

wainuitech
17-07-2016, 05:42 PM
Couple of things to try.

1st Plug something else in the Same USB port that you were using for the cam ( like a flash Drive) - Does it detect and work. If yes then the port is OK, if not then there's problems with the port or USB drivers.
2nd. Open Device manager - are there any exclamation Marks in expanded USB controllers , or any other indications that somethings not right with the USB ports. If the cam is not plugged in then plug it in, the USB should expand out with faults or the cam should detect under Imaging ( I think) in the device manager.

Pato
17-07-2016, 06:57 PM
Couple of things to try.

1st Plug something else in the Same USB port that you were using for the cam ( like a flash Drive) - Does it detect and work. If yes then the port is OK, if not then there's problems with the port or USB drivers.
2nd. Open Device manager - are there any exclamation Marks in expanded USB controllers , or any other indications that somethings not right with the USB ports. If the cam is not plugged in then plug it in, the USB should expand out with faults or the cam should detect under Imaging ( I think) in the device manager.The USB port tests ok. There are no exclamation marks. I think I will uninstall/reinstall Skype. Should I also uninstall both drivers, the one recommended for win10 which didn't detect the Cam, and the one I tried for win7 which was incompatible, but I tried in desperation. If so which is the way I should uninstall Skype and the drivers.?

KarameaDave
17-07-2016, 08:30 PM
Uninstall the driver and reinstall in compatibility mode.

So go to device manager right click on the webcam and uninstall the driver.
Then right click on the driver .exe select properties, go to the compatibility tab and select the version of windows your driver was intended for.
this works in most cases.

wainuitech
17-07-2016, 08:34 PM
If the Software is not detecting the cam , but did install OK then something is blocking it. Could be corrupt drivers.

Try this -- When you plug in the Cam, does it make the plink sound that its attached ? At the same time open device manager - look to see if its listed in any of the USB controllers, BUT it should be listed under imaging.

Click in the search, type in Troubleshoot, select it, from the options "Hardware and Sound" select Configure a Device -- Run the troubleshooter, see if it can fix the problem.

Edited: just checked on SWMBOs computer she has a C210 - its under Imaging Devices, uses the same windows 10 software and works fine.

apsattv
18-07-2016, 02:46 AM
In windows 7 these cams always worked with a default windows USB driver. "USB Video Device" under "Imaging Devices"

You then would install the official logitech driver over top if you wanted the advanced functions

Go to windows update and check for optional, hardware driver updates?

Pato
19-07-2016, 11:40 AM
Just an update and to say thanks to all who helped me sort out this problem. After some uninstalling/reinstalling of software and drivers all is working well.