PDA

View Full Version : DDNS Huawei HG630b



Tbird650
29-03-2015, 11:45 PM
I'm struggling to set my Spark supplied Huawei HG630b router to dynamic update dns so I can view my home security cameras. I had it working with the earlier Thomson router but switching to VDSL meant a new one was needed. I have a no-ip.com account and have been using the service. It will work if run Dynamic update client DUC v4.1.0 but it would be much more convenient if the router sorted it automatically.

A possible solution could be to update the Huawei firmware. I note that on the DDNS page, no-ip.com is not listed as a service provider so I can only choose "others" option.
Spark does have an updated firmware available but I'm a bit hesitant to do it and of course no idea if it will fix the problem. Has anyone updated??

In searching for a solution I read where some "Home gateway" DDNS needed a host name less than 10 characters so I swapped to a new shorter no-ip hostname and edited the router and DVR but the issue continues.

OK, a couple of queries please for my router DDNS settings.
What should the 'server address' be? I have it as dynupdate.no-ip.com after locating it with Mr.Googles' help.
Server name: no-ip.com
Server port: 80
Protocol: GNUdip.http

Edi: I found a no-ip webpage that looked like it was suggesting to use http://dynupdate.no-ip.com/nic/update as the server address. This did not work.

Thanks.

Chilling_Silence
30-03-2015, 01:18 PM
Sounds like it's worth grabbing a newer firmware, it's plausible that no-ip have changed the way they handle receiving updates?

Tbird650
31-03-2015, 12:26 AM
Thanks Chill,

I updated the firmware and it went well. The problem was not solved though. Another Google search turned up a very interesting thread (http://www.talktalkmembers.com/t5/Unlimited-Broadband/DDNS-settings-on-HG533/td-p/844595)

Summary,,,
...there is a bug in the GNUDip.http implementation on all Huewai TT routers - the salt, sign and pass parameters are not correctly passed to the server - they are sent, but missing the last character in each case. So, with an incomplete password hash sent by the router, the remote server will be unable to verify it.

Looks like I'm out of luck for the time being.

Chilling_Silence
31-03-2015, 01:14 PM
Unfortunately they really are just nasty routers :-/

Tbird650
31-03-2015, 09:45 PM
I fixed the DDNS problem. I got another free account with DuckDNS (https://www.duckdns.org/). It couldn't have been much simpler. DuckDNS support the GnuDIP.http protocol and wrote a "how-to" on their "install" page. I updated all my DVR, DDNS, router etc settings, then to test I restarted everything from scratch 3 times. Each time DuckDNS sorted the address without fuss.
So at this moment it's all looking good.