PDA

View Full Version : One for the Website Guru’s



B.M.
14-10-2014, 05:19 PM
Well I’ve fiddled around with my first website and whilst it is pretty amateurish, it is going, and improvements will be made along the way. :)

Webdevguy has been a big help with layout suggestions but my present problem relates to the “Contact Us” page which is supposed to return an automatic reply.

Well it does, if you have a G-Mail account. However, if you have a Hotmail/Outlook account it reply’s with the Header & Footer but omits the message, and if you have any other account you get everything bundled in amongst a heap of code.

I have taken the matter up with OpenHost and am waiting to hear if they can throw any light on the matter.

In the meantime, I thought I’d check if anyone here has already been down this road and has the answer. :)

pcuser42
14-10-2014, 05:49 PM
Probably sounds like the email message isn't being sent as an HTML message properly, but Gmail is rendering it as HTML anyway.

B.M.
14-10-2014, 07:16 PM
The manual for the programme I used to make the Website says this (among other things), about the “Contact Us” facility.

5981

Webdevguy
14-10-2014, 07:59 PM
The manual for the programme I used to make the Website says this (among other things), about the “Contact Us” facility.

5981

I'm thinking the latter part of that message will be what the problem is since virtually every web host supports PHP.

Webdevguy
14-10-2014, 08:08 PM
Well I’ve fiddled around with my first website and whilst it is pretty amateurish, it is going, and improvements will be made along the way. :)

Webdevguy has been a big help with layout suggestions but my present problem relates to the “Contact Us” page which is supposed to return an automatic reply.

Well it does, if you have a G-Mail account. However, if you have a Hotmail/Outlook account it reply’s with the Header & Footer but omits the message, and if you have any other account you get everything bundled in amongst a heap of code.

I have taken the matter up with OpenHost and am waiting to hear if they can throw any light on the matter.

In the meantime, I thought I’d check if anyone here has already been down this road and has the answer. :)

When you created the website did you put it in its own folder on your computer?

B.M.
15-10-2014, 07:25 AM
When you created the website did you put it in its own folder on your computer?

No I didn't but it looks like I can.

5982

B.M.
16-10-2014, 10:33 AM
Update.

Well, I explained the problem to OpenHost and got the following reply:

5984

So, I took the matter up with the guys who sold me the programme WebSite X5 Evolution and got the following reply from them:

5985

It would seem that it works fine for some and not for others.

Therefore, I wonder if some of our members would be good enough to log onto sockaid.co.nz and leave a short message on the contact us form. You should get an automated reply which should read:

5986


Is it all there, or, is the message missing, and does it come without being buried in code, also, which ISP’s work and which don’t?

:thanks

pcuser42
16-10-2014, 11:08 AM
Displays fine in Outlook 2013 (connecting to Gmail).

5987

For interest, here's the headers that came with it:



Delivered-To: <REDACTED>
Received: by 10.64.55.165 with SMTP id t5csp709795iep;
Wed, 15 Oct 2014 15:01:42 -0700 (PDT)
X-Received: by 10.66.149.136 with SMTP id ua8mr9824009pab.6.1413410502239;
Wed, 15 Oct 2014 15:01:42 -0700 (PDT)
Return-Path: <<REDACTED>>
Received: from linuxplesk3.openhost.net.nz (linuxplesk3.openhost.net.nz. [112.109.81.136])
by mx.google.com with ESMTPS id n3si8124544pdr.18.2014.10.15.15.01.41
for <<REDACTED>>
(version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
Wed, 15 Oct 2014 15:01:42 -0700 (PDT)
Received-SPF: softfail (google.com: domain of transitioning <REDACTED> does not designate 112.109.81.136 as permitted sender) client-ip=112.109.81.136;
Authentication-Results: mx.google.com;
spf=softfail (google.com: domain of transitioning <REDACTED> does not designate 112.109.81.136 as permitted sender) smtp.mail=<REDACTED>;
dmarc=fail (p=NONE dis=NONE) header.from=gmail.com
Received: by linuxplesk3.openhost.net.nz (Postfix, from userid 10524)
id 642051081F3; Thu, 16 Oct 2014 11:01:40 +1300 (NZDT)
To: <REDACTED>
Subject: =?UTF-8?B?U29ja0FpZA==?=
X-PHP-Script: sockaid.co.nz/imemail/imEmailForm.php for 27.252.223.202, 27.252.223.202
From: <REDACTED>
Message-ID: <141341050023@websitex5.users>
X-Mailer: WebSiteX5 Mailer
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="f66c7f66145dd474552270d5155f4701"
Date: Thu, 16 Oct 2014 11:01:40 +1300 (NZDT)

B.M.
16-10-2014, 11:33 AM
Thanks for that PC User. :thumbs:

B.M.
16-10-2014, 11:41 AM
Don't know if this will work, but here is the response back to Thunderbird via clearnet/vodafone.



Message-ID: <141339781891@websitex5.users>

X-Mailer: WebSiteX5 Mailer

MIME-Version: 1.0

Content-Type: multipart/alternative; boundary="d1114ea2f7f5a19fa29410e7b5dbe0f1"
Date: Thu, 16 Oct 2014 07:30:18 +1300 (NZDT)

--d1114ea2f7f5a19fa29410e7b5dbe0f1

Content-Type: text/plain; charset=UTF-8

Content-Transfer-Encoding: 8bit



Thank you for contacting us. This is an automated response confirming the receipt of your message.

We shall reply shortly.

Regards

SockAid Team.





--d1114ea2f7f5a19fa29410e7b5dbe0f1

Content-Type: text/html; charset=UTF-8

Content-Transfer-Encoding: 8bit



<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta http-equiv="content-type" content="text/html; charset=utf-8">
<meta name="generator" content="Incomedia WebSite X5 v10 - www.websitex5.com">
</head>
<body bgcolor="#708090" style="background-color: #708090;">
<table border="0" cellpadding="0" align="center" cellspacing="0" style="padding: 0; margin: 0 auto; width: 700px;">
<tr><td id="imEmailContent" style="min-height: 300px; padding: 10px; font: normal normal normal 9.0pt Tahoma; color: #000000; background-color: #FFFFFF; text-align: left; text-decoration: none; width: 700px;border-style: solid; border-color: #808080; border-top-width: 1px; border-right-width: 1px; border-bottom-width: 0; border-bottom: none; border-left-width: 1px;background-color: #FFFFFF" width="700px">
Thank you for contacting us. This is an automated response confirming the receipt of your message.<br />
<br />
We shall reply shortly.<br />
<br />
Regards<br />
<br />
SockAid Team.
<br><br>

</td></tr>
<tr><td id="imEmailFooter" style="font: normal normal normal 7.0pt Tahoma; color: #000000; background-color: transparent; text-align: center; text-decoration: none; width: 700px;border-style: solid; border-color: #808080; border-top-width: 0; border-top: none; border-right-width: 1px; border-bottom-width: 1px; border-left-width: 1px; padding: 10px; background-color: #FFFFFF" width="700px">
This e-mail contains informations that are intended solely for the above mentioned addressee.<br>If you have received this e-mail in error, please notify the sender immediately and destroy it, without copying it.
</td></tr>
</table>
</body>
</html>

wainuitech
16-10-2014, 12:02 PM
:2cents: If its still giving problems, One thing to get them to look at -- When I first setup my own site with Web drive (same as open host) the reply form I have wouldn't work correctly and the automatic reply message wouldn't pop up like it was designed to. Using the same software WebsiteX5.

It was found that the site has to be hosted on one of their Linux based servers, not a Windows Server, it was something to do with the WebsiteX5 program not liking the windows server. Once they changed over to Linux based its worked perfectly all the time.


May or may not be the same sort of problem.
:2cents:

B.M.
16-10-2014, 12:43 PM
Thanks Wainui, I think I may be onto it, I'll report back shortly.

In the meantime don't worry about any testing anyone as I'm playing with the site. :D

B.M.
16-10-2014, 01:10 PM
Problem Resolved! :clap

There was a setting under advanced, whereby you can change the Server Script from Standard to Low Quality.

Changed that and we seem to be fixed.

Must say I like this programme and the help is great, even if it is on the other side of the world.

:thanks to those who contributed.

5988

Webdevguy
16-10-2014, 01:58 PM
Problem Resolved! :clap

There was a setting under advanced, whereby you can change the Server Script from Standard to Low Quality.

Changed that and we seem to be fixed.

Must say I like this programme and the help is great, even if it is on the other side of the world.

:thanks to those who contributed.

5988
That's great news BM.
Glad you like the program.

Btw, have you got Microsoft text editor on your PC?

B.M.
16-10-2014, 02:30 PM
That's great news BM.
Glad you like the program.

Btw, have you got Microsoft text editor on your PC?

I've got Word out of Office does that count as a Text Editor?

pcuser42
16-10-2014, 02:37 PM
I've got Word out of Office does that count as a Text Editor?

No. :p

Webdevguy
16-10-2014, 02:54 PM
I've got Word out of Office does that count as a Text Editor?

Nope, MS Word is a document editor not a text editor.