PDA

View Full Version : Virtual memory sieze up



linw
11-05-2014, 04:49 PM
Had a really strange issue when I went to this comp this morning. It was functioning but there was no video. Pressed the sleep button and it slept. Pressed a key and it woke with video. No taskbar showing but the icons could be used - they were just invisible!

Long and short, about 4am windows 8.1.1 started complaining of running low on virtual memory. Said it was increasing it. Several running progs crashed 'cos of low memory or lack of resources. Event viewer said IE and T'bird were using amounts as here:-

"Windows successfully diagnosed a low virtual memory condition. The following programs consumed the most virtual memory: iexplore.exe (5260) consumed 248,193,024 bytes, iexplore.exe (1644) consumed 247,341,056 bytes, and AdblockPlusEngine.exe (3980) consumed 186,527,744 bytes".

Pagefile size had been increased to 24GB.

No BSOD dumps were created. Memtest was OK. chkdsk fixed 1080 index errors. Pagefile now 1.728GB.

Not looking for a solution but wondered if anyone had seen anything like this before? Pretty sure I haven't and hope I won't again. Seriously weird. Or is it??

(C:=250GB SSD. Pagefile is on C:).

Agent_24
11-05-2014, 08:23 PM
Sounds like something (probably IE) was using far too much memory and Windows was running so slowly trying to deal with it that it couldn't respond fast enough for anything else to work properly.

linw
12-05-2014, 10:42 AM
Yeah, probably the best guess. IE could have gone feral and gobbled all the RAM (8GB installed). This IE11 is not that stable I'm afraid.

Oooops. 'seize' - i before e except after c doesn't always work!

And putting a colon before a right bracket is a bummer.

dugimodo
12-05-2014, 11:37 AM
Yeah but C:\) or C: ) both work :)

I've seen the no video on resume from sleep often enough, avoided using sleep for many years because it happened to me too often.
The rest sounds like a memory leak, hopefully just a one time glitch. Wouldn't hurt to scan for Viruses and Malware as a precaution.

Agent_24
12-05-2014, 02:22 PM
Probably no video caused by Windows waiting for IE etc before it could re-initialise the video card after waking.

linw
12-05-2014, 02:55 PM
Sounds feasible, Agent.

Scans clean, Dugi.

Hopefully, just one of those weird one-offs.

Speedy Gonzales
12-05-2014, 03:06 PM
Probably a corrupt page file. It can do strange things, when its screwed

dugimodo
12-05-2014, 03:30 PM
Coincidentally I just had issues with my swap file :) Self inflicted though, I copied my D: drive and replaced it and apparently copy - pasting the swapfile doesn't work.
It's now on my SSD and I'm not sure if I will put it back (drive wear vs performance hmmmm).

linw
12-05-2014, 04:53 PM
Yeah, Speedy, that could be an answer. We'll never know!!