PDA

View Full Version : How to Upgrade XFree86-libs-4.0.3 to version 4.1.0???



08-12-2001, 12:26 AM
Hi,

Title says it all really, how do I upgrade to the aforementioned version? When (in a terminal window, after Cd'ing to the directory containing the rpm) I type the following command:

rpm -Uvh Xfree86-libs-4.1.0-21.mdk.i586.rpm

It gives me the following error:

error: failed dependencies:
XFree86-libs = 4.0.3-7mdk is needed by XFree86-xfs-4.0.3-7mdk
XFree86-libs = 4.0.3 is needed by XFree86-4.0.3-7mdk

What's wrong? I can't uninstall XFree86-libs-4.0.3 without taking almost the entire operating system with it... so Obviously I want to upgrade, but why doesn't it let me?

Thx in advance!

:)

08-12-2001, 12:12 PM
What is happening here is that there is another package on your system (XFree86-xfs) that can only function if you have the 4.0.3 version of XFree86-libs.

The first thing that I would suggest is to try to find a package called 'XFree86-xfs-4.0.10'. Install that, and then you should be able to install the 4.0.10 version of XFree86-libs.

09-12-2001, 12:18 AM
Hi,

Thanks for your help, that worked, I have now installed XFree86-libs-4.1.0 and -xfs-4.1.0. Now, when I try to install:

OpenGL-core-4.1.0-8.i686.rpm

It says:

file /usr/X11R6/lib/libGL.so.1.2 from install of XFree86-OpenGL-core-4.1.0-8 conflicts with file from package XFree86-libs-4.1.0-21mdk
file /usr/X11R6/lib/libGL.so.1.2 from install of XFree86-OpenGL-core-4.1.0-8 conflicts with file from package XFree86-libs-4.1.0-21mdk

The underlying mission here is to get PC Worlds Quake3 demo working... I have already established that in order to get it working I need to:

Upgrade XFree86-libs to 4.1.0 (done)
Install XFree86-OpenGL-core
Install XFree86-OpenGL-lis

Then that's one less error that shows when I load quake, then I can work on the next one! However, when I go into software manager, and search for 'XFree86' under installed, it shows that all the 4.1.0 things I have installed are version 4.0.3 still...what gives??

Thx:)

Erin