PDA

View Full Version : website on internal home network



Mike
16-07-2013, 08:18 PM
I have a webserver running on my main PC which I want accessible to other devices on the network (but not exposed to the internet...)

currently when I browse to my computer-name from my tablet I get a Webpage not available.

Do I need to forward ports or open ports or whatever to get this to work?

Cheers,
Mike.

inphinity
16-07-2013, 08:27 PM
You'll need whatever firewall is running on the local PC to allow connections on port 80 for http and 443 for https if you're using it (or whatever custom ports you've define). No, you don't need to do any port forwarding for LAN.

fred_fish
16-07-2013, 08:27 PM
Does "computer-name" resolve to the correct machine?
Can you ping it by name?

Mike
16-07-2013, 08:39 PM
OK so I tried pinging from my tablet (an android), both on name and ip and both get destination host unreachable. I have turned off (for testing purposes) the firewall (Windows kindly popped up a message warning me that no firewalls were running), same result - Destination Host Unreachable.

Mike.

fred_fish
16-07-2013, 09:06 PM
Are they on the same subnet?
What is your network configuration?

Mike
16-07-2013, 09:11 PM
I assume so? Router controls everything - DHCP in range 10.1.1.4 to 10.1.1.32, subnet mask 255.0.0.0

I am able to browse my PC shared drives and access pc services such as windows media server - just don't seem to be able to access this website.

Mike.

fred_fish
16-07-2013, 09:36 PM
The lack of a ping response to the ip is suspicious and maybe points to a firewall still being on.
Can you portscan your pc (from inside your LAN) with nmap (or android equivalent)?
If shares are available you should get a positive response on the SMB ports at least, which will also confirm basic connectivity, and a 'closed' on 80 will mean an active firewall or a misconfigured webserver (listening on the wrong interface or such).

inphinity
17-07-2013, 09:45 AM
Presumably you can browse the site from the PC it's hosted on? The host unreachable response to ping is concerning, if the firewall is indeed off.

Chilling_Silence
17-07-2013, 12:40 PM
Yeah two things to test:
1) On the PC that's hosting, can you bring it up by going to 127.0.0.1
If you can, then the web daemon is at least running
2) If you cannot browse to it then from another PC on the LAN, firewall issue most likely... OR it's a misconfiguration of the HTTP daemon and it isn't listening for requests from anything but the localhost.

So, what web server software are you using ?

Mike
17-07-2013, 06:02 PM
<facepalm> ok so my IP address wasn't what I thought it was :D lol, so I have my tablet able to access the website now, but only with the firewall off. Firewall on and it times out. Any suggestions on making Comodo open to internal IPs? I thought I'd done it, but it doesn't appear to be working.

Mike.

wainuitech
17-07-2013, 06:31 PM
<facepalm> ok so my IP address wasn't what I thought it was :D lol, so I have my tablet able to access the website now, but only with the firewall off. Firewall on and it times out. Any suggestions on making Comodo open to internal IPs? I thought I'd done it, but it doesn't appear to be working.

Mike.
Dont Actually use Comodo, haven't for years - But most Firewalls have the options to allow either certain IP Addresses through, or a range. You want to set the IP range from the starting and ending of the routers range, that way it doesn't matter what IP address the router gives what device it will be allowed through. In your case I'd put in 10.1.1.1 to 10.1.1.32 Or higher on the last address.

Wonder why the router is only set for 32 Addresses - limits its range a lot ?

Did find the following, yours may be the same, but its a starting point.
http://help.comodo.com/topic-72-1-451-4884-Network-Zones.html

Mike
17-07-2013, 06:37 PM
Dont Actually use Comodo, haven't for years - But most Firewalls have the options to allow either certain IP Addresses through, or a range. You want to set the IP range from the starting and ending of the routers range, that way it doesn't matter what IP address the router gives what device it will be allowed through. In your case I'd put in 10.1.1.1 to 10.1.1.32 Or higher on the last address.

Wonder why the router is only set for 32 Addresses - limits its range a lot ?

Did find the following, yours may be the same, but its a starting point.
http://help.comodo.com/topic-72-1-451-4884-Network-Zones.htmlI set the router limit manually, just cause :)

I thought I had set the firewall to allow all ports in/out for IP range 10.1.1.2-10.1.1.32 which I assumed would work, but it didn't. I'll try out the instructions on that link.

Mike.

wainuitech
17-07-2013, 11:11 PM
If its set to allow all the IP ranges ( you set) and comodo is still blocking, it may not be the IP address thats being blocked, it may actually be the web page / application ( or something else) directly

WarNox
18-07-2013, 08:47 AM
Try allowing port 80 inbound on the firewall from any address. It doesn't matter if it seems to be open to the Internet anyway, if you don't have NAT set up external users won't be able to get to it anyway.