PDA

View Full Version : Windows 7 Aero not working



Nikit07
23-05-2013, 09:50 PM
Hey all!
I am back... with another problem. :P
Windows Aero seems to have stopped working. So now I am just running the windows "Basic" theme and I can't change back!
I've searched the internet for a solution and none of them worked! I tried restarting my PC, updating my Graphics drivers, Running CCleaner, uninstalling a bunch of junk, running the Microsoft Fixit software, troubleshooting aero, stopping certain background processes and a whole lot more.
Fixit says my GPU dosn't support aero when it does because It was working for a year earlier and you can see my specs down below. Sooooo I'm stuck.
Any of you have any experience with such and issue or know how to resolve it?
All replies appreciated :)
Thanks!

Speedy Gonzales
23-05-2013, 09:55 PM
Is the BIOS up op date?? Looks like this can cause Aero not to work. Don't ask me how tho. But on one site someone had the same card (but an MSI)_. Aero didnt work either till he/she updated the BIOS

Nikit07
23-05-2013, 09:59 PM
My BIOS version is the American Megatrends Inc. F14, 31/5/2012. Went on their website to see how to update it and it simply says:
1. Identify your BIOS and motherboard
2. Contact your motherboard manafucturer
Which I'm not planning to do any time soon.

Speedy Gonzales
23-05-2013, 10:01 PM
Well that doesnt tell us much. Unless you tell us or know what the brand /model of the mobo is. If its an ASUS all you do is use it in windows, or use ez-flash in the BIOS if it supports it

Nikit07
23-05-2013, 10:03 PM
Pretty sure it's a Gigabyte board, i'll double check and get back to you with the particular model.

Speedy Gonzales
23-05-2013, 10:04 PM
K

Nikit07
23-05-2013, 10:12 PM
When I check my system specs on the model number it says "To be filled by O.E.M."
Checked an Instruction booklet which I got with my PC and it has 3 different model numbers on the front.
Only one of them is a Z77, the other two are H77 models. In my pressf1 signature it says Z77 chipset motherboard. I pasted that from my PC on the PB tech website so I am 90% sure that the Mobo that I have is the Gigabyte GA-Z77-D3H.

wainuitech
23-05-2013, 10:23 PM
Your Operating system has corruption, doubt its got anything to do with the board. ( since it used to work OK)

Start the computer as normal, open a command prompt, click start, type in cmd, when it appears right click run as administrator, type in sfc /scannow <press Enter> - let it run, once finished, reboot, see if Aero returns, in not run chkdsk / r ( same as before from the CMD) You'll get a message saying it cant run do you want to run on next reboot, type Y <press Enter> then reboot, chkdsk will run - don't stop it.

Nikit07
23-05-2013, 11:06 PM
Hi wainuitech! I did both of the scans and they said that they found and fixed some stuff. Restarted PC (it did the second scan there) I logged on and it was still windows 7 basic without aero themes. Went into the control panel and played around a bit
trying to get it to work but finished without luck. This aero problem started after I installed FSX (Flight Simulator X) onto my PC. When I start up FSX it changed the theme to basic and when I exit it's supposed to change back. That's what happened on my old 2 computers and with previous installations of FSX on this computer (I uninstall and reinstall FSX often because it takes up a lot of space). But one time when I exited FSX it didn't switch back to normal and this is how the problem started. I don't want to uninstall FSX because then I'll loose all my addons which I spent ages manually installing.

wainuitech
23-05-2013, 11:30 PM
OK that confirms it really, sounds like FSX has somehow altered the graphic settings, by disabling / Breaking Aero.

Found this - No idea if it will work or not as I cant replicate your problem.: Quoted from http://answers.microsoft.com/en-us/windows/forum/windows_7-desktop/windows-7-aero-disabled-how-can-i-enable-it-again/aa760f0f-eec1-4a36-b212-c96130038d5c?page=3 Expand out the answers, as some are relating to FSX as well. Same Problem ( where there is a arrow/ In Reply to <Person Mentioned> )


Force Enable Aero in Windows 7

1. Click on Start and type regedit at run



2. Now Navigate to the following registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM



3. In the right details pane, create following Three DWORD (32-bit value) entry

UseMachineCheck, and set its value to 0.

Blur, and set its value to 0.

Animations, and set its value to 0.



4. Close Regedit



5. Click on Start and type CMD with administrative Priviliges



6. Now type following command

Net Stop uxsms

Net Start uxsms

Above command will stop and start Desktop Window Manager Session Manager.



7. Now you can turn on Aero by right clicking on desktop-> Personalize -> Select Windows Colors

Nikit07
24-05-2013, 10:15 AM
Ok thanks! I shall try that when I get home :)

Nikit07
24-05-2013, 06:15 PM
I tried doing what the post suggested but I noticed a part where it says "In the right details pane, create following Three DWORD (32-bit value) entry" I have a 64 bit system so will that make a difference? And also it says
"Now Navigate to the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM"
But when I got into the HKEY_CURRENT_USER folder all I see is this: 5004

wainuitech
24-05-2013, 07:47 PM
Where it says DWORD (32-bit value) use that option, don't worry that you have a 64Bit OS.

You have to click on the arrows to expand out the keys -- make sure follow the path EXACTLY other wise you can do ALOT of damage.
Example:
5005
Editing the registry is a dangerous business if you don't do it right, as its the whole backbone of your OS ( in simple terms)

When you get the right path end, you'll have similar to this:

5006

If you get lost then STOP -- dont guess - if you need more help to enter the reg keys Either myself or someone else may be able to make up a reg file to automatically enter the settings.

I cant do it tonight, I'm busy.

Nikit07
24-05-2013, 09:21 PM
Thanks for your help wainui! I did exactly as you and the instructions said. Went into control panel and still aero dosn't work. Restarted PC and still no aero. Guess I'm stuck with basic :/

wainuitech
24-05-2013, 09:49 PM
So you managed to enter the reg keys OK and run the commands as per the article ??

If you haven't already have a look at the link there were a couple of other suggestions as well.

Can you do something please:

Go into the Registry where the DWORDS ( DWM Folder) were created, take a screen shot of the complete list of all the keys that are there, ( same as the one I posted) and post it back here like the one you posted before- Lets have a look at whats there and as a comparison on a PC that has Aero working.

Nikit07
24-05-2013, 10:03 PM
As you requested wainui. :)
5008

Nikit07
24-05-2013, 10:15 PM
I FIXED IT!! :D My Desktop Window session manager was disabled! Thanks for all your help though! :)
Edit: Ohh yesss the aero goodness is finally back! No more of that disgusting light blue on top of my dark abstract wallpaper! ^_^

wainuitech
24-05-2013, 11:52 PM
That may have happened because earlier on you mentioned you were playing around with various settings ( original post) the reg entries + commands given in the suggestion should have stopped /started it again, but if it was disabled it couldn't :)

Good you got it going.

Agent_24
25-05-2013, 12:05 AM
I am 90% sure that the Mobo that I have is the Gigabyte GA-Z77-D3H.

Just take the side off your case and look at the motherboard. The model number\revision number etc and all will be silkscreened on the board in white lettering (somewhere)