PDA

View Full Version : Windows 8 network printer failed to print after NAS install



Eorr
10-01-2013, 06:07 PM
Thanks for viewing.

I am totally stumped by this one; Running windows 8 since November; Everything installed OK including wireless network printer - Brother HL-3070cn; In December I installed a WD Mybook Live NAS drive and have it connected to my wireless router by ethernet cable;

The NAS gave me a few headaches but I eventually got access using mapped drives on all my PC's here at home - 2 PC's running windows 8, 1 Laptop running Win XP, and another laptop running Win 7; Over the wireless signal and main win 8 PC by ethernet.

I am not sure if installing the NAS drive did it, but I can no longer print to the printer on the network from my Windows 8 PC's - it is OK from the laptops. I am even able to ping the printer from windows 8 cmd window and can even open the management page through internet browser and print a test page; I have been hammering away at the port settings on the printer in Windows 8 to no avail. It is presently using the original port created by Windows which was working previously.

Uninstalling the printer and adding it back and Windows 8 detects it on the network and asks what driver to use - existing or new give same result; Seems to be all good but get the error message that the test page failed to print. Windows even tells me that the printer is running low on colour store, but fails to send anything to the printer.

So my only thought is to do with the homegroup settings but don't know what to adjust through those settings. The homegroup troubleshooter only recommends adding printer sharing ability (which I think should be irrelevant as it is a network attached printer not a local one shared over the network, but tried that anyway with no luck). Network troubleshooter is not very helpful.

Any ideas anyone? Appreciate your time.

wainuitech
10-01-2013, 07:37 PM
Try leaving the Homegroup - Homegroup can cause all sorts of problems. Good ol fashioned networking generally works better. This is only a test to see if it is homegroup causing the problem.

Eorr
10-01-2013, 10:22 PM
Try leaving the Homegroup - Homegroup can cause all sorts of problems. Good ol fashioned networking generally works better. This is only a test to see if it is homegroup causing the problem.

OK, I liked that idea but it had no affect.

But... I found a major clue as to what the problem is - administrator privileges are not available for the printer for some reason. If I right-click the printer icon and select 'properties' I am unable to print test page; if I right-click and select 'run as administrator -> properties' I can print the test page OK.

So now, how to apply administrator rights to a printer?

wainuitech
10-01-2013, 10:45 PM
Well done, that's a huge clue. What you can do is Force W8 to run ALL programs with admin rights, should fix it, Found an article a short while back to do this.

Heres a test, if you open a CMD and type in sfc /scannow it will refuse to run with out admin rights. after this change ALL programs will run with Admin rights.

hit the windows key, go to the start menu screen.

Type secpol.msc search will open and it will display, RIGHT click it run as admin

Double click on Local Policies then double click on Security Options.

Scroll to near the bottom to this entry

User Account Control: Run all administrators in Admin approval mode.

Double click that line.

Set it to disabled then press OK.


Reboot the computer - once it reboots ALL programs will now be running as Admin, to test open cmd again, type in sfc /scannow, this time it should run - previously you will have had to right click, run as admin.

Try your printer ( Fingers Crossed) :)


NOTE: One side effect is the Windows Store app wont work any more till you reverse the setting.


Cant see how things are setup, but if you have the run as admin available on your printer, right click look for a compatibility tab, if it has one, down the bottom will be a check box to allow the option to run that only always as admin.

Eorr
10-01-2013, 11:10 PM
Yep, that worked.

So very good progress. Thanks for your expert help.

Now I need to figure out what has caused this change to occur within the last few weeks, as it used to work OK.

I'll also look at your last comment tomorrow and will post back any further progress for the record.

Cheers for that! :thumbs: