PDA

View Full Version : Canon MG4160 on Mac



berryb
26-11-2012, 10:06 PM
New Canon MG4160 installed on Mac 10.4.11 and will not print via wireless. Works fine on USB. Printer is connected to wireless and can access the printer web page via web browser and IP address. Canon install software says it detects the printer but doesn’t give the option to install the printer. Have downloaded the driver directly from Canon and installed but doesn’t show as an available printer when installing. Have tried to manually install using the IP address and print jobs say they have completed but nothing out of the printer.

wainuitech
26-11-2012, 10:18 PM
This isn't going to be any help, but had the exact same printer give the exact same wireless problem with two Windows PC's a week or so back both W7's.

One could connect fine, the other simply couldn't see the printer at all via wireless. Tried a different wireless printer and both PC's connected perfectly first time. In the end we used a USB on the one that didn't detect.

plod
26-11-2012, 10:29 PM
How have you set this up on the mac?, have you tried setting up through IP.printer?

berryb
26-11-2012, 10:49 PM
wainuitech - have had issues with wireless printers as well. Normally a restart of the modem/switch and printer sorts things. If not general a DCHP issue on the crap Telecom adsl modems.

plod - used the CD for Mac install that came with the printer. Said the printer was configured for the network so had to be able to communicate with the printer at this stage. It then installed the default driver and software and at the end of the install process said to add the printer by selecting the printer but the printer did not show as an option to install.

I then checked and found I could access the printer via it's web interface by going to it's IP address. I then downloaded the driver from the Canon site and tried to install as an IP printer. Normally since the printer driver is installed you can select the printer and it works but the printer is not in the printer list. When set as a generic post script the print job goes to the printer and the laptop show it as being printed but the printer will not be post script enabled.

Plugged in the usb cable and works fine.

wainuitech
27-11-2012, 08:04 AM
Dont know if this is will be of any use, but earlier this year I had to get an iPad talking to a canon Wireless printer - the PC that was in the room could connect OK, but to get the Ipad to work after calling Canon, we had to upgrade the printers "AirPrint Firmware" then the iPad would see the printer. We had to download it and install Via a USB.

I did look and there is a AirPrint Firmware dated 25-Jul-2012 for a MAC :2cents: ( only a suggestion, no idea if it will help or not)

Jeff
27-11-2012, 01:28 PM
When you set the IP address for the printer on the Mac, did you set the Protocol as HP Jetdirect - Socket?
Have found this is best for the printers I deal with.

nedkelly
27-11-2012, 03:17 PM
FYI, when adding Canon inkjet printers you are meant to be on default option in the add printer area of print and fax not IP, the IP option from memory is only for the MF or LBP machines. (not 100% sure with 10.4 dont do many support calls for it any more)
Airprint firmware updater only enables airprint for iOS devices and Mac OS X 10.8, does not support 10.4

Speedy Gonzales
27-11-2012, 03:30 PM
On mine which is also wireless the wireless printer (I had to connect it to USB to install the drivers). And the printer for it, ends with WS. It needs to be on this to print / scan wirelessly (on here anyway)

nedkelly
27-11-2012, 04:40 PM
Macs you just install the MP Drivers or Cups and Scanner driver and then as long as the printer is wirelessly connected to the same network as your computer then you should see it in the add printer area and you can add it.

berryb
30-11-2012, 10:13 PM
Thanks for the reply's. Been away for a few days so haven't followed up on this yet.

As stated I installed the driver from both the supplied CD and webiste. It doesn't show as an available printer except using Bonjour but this doesn't work. I'll check some of the suggestions and come post back.

Cheers