PDA

View Full Version : How to stop a secondary HDD from spinning down?



powerover
04-08-2012, 07:28 PM
Hi all,

My Asus G74sx have 2 HDDs, the first one is a SSD and a second one is a 7200rpm HDD.

The SSD is only 60GB so I install all my programs on the second HDD, keeping the SSD for windows
only.

The problem is it spins down, really quick, so when ever I do something it takes extra long, I got to
wait for the HDD to spin up (I can hear that very clearly), which takes a couple of seconds everytime,
and it gets very very annoying..:badpc:

Is there a way to stop that from happening? I tried the windows power settings, setting the "Turn off HDD
after.." to "Never", and it never helped...reading some online forum, others suggested that I should turn
off s.m.a.r.t..but when I boot into the BIOS there is no such options..:badpc:

Any kind of help will be greatly appreciated.

ronyville
04-08-2012, 10:12 PM
If the 2nd drive is a green drive than I think its part of the firmware to power down to save power.....

Found this software that you can try, have not tried it myself so not sure how good it is ..

http://softjock.com/mdis.htm

MistyCat
04-08-2012, 11:10 PM
When I had the same problem about 10 years ago, the solution was an updated BIOS flash. The drive was a Seagate, but I have no memory now of the brands of mobo or CPU.

powerover
05-08-2012, 09:06 AM
If the 2nd drive is a green drive than I think its part of the firmware to power down to save power.....

Found this software that you can try, have not tried it myself so not sure how good it is ..

http://softjock.com/mdis.htm

I think the second drive is a seagate HDD, and you are right, from memory, it is a green drive....

will try that software and get back to ya. :D

powerover
05-08-2012, 09:55 AM
http://softjock.com/mdis.htm

Doesn't work......:(

gary67
05-08-2012, 10:04 AM
I have the same problem with a WD drive that is my data drive, I haven't been able to find a solution so just live with it

bk T
05-08-2012, 10:18 AM
Have you tried this:

Control Panel -> Power Options -> Change Advance power settings -> Hard disk -> Turn Off hard disk after _____



Edit: just ignore the above. - since you have done that!

McRuff
05-08-2012, 11:53 AM
I was having a similar issue with my Data Drive. To stop it spinning down as often I put a small swap file on it. Didn't seem to effect computer performance negatively, but I am not constantly waiting for it to spin up now

powerover
05-08-2012, 01:10 PM
I was having a similar issue with my Data Drive. To stop it spinning down as often I put a small swap file on it. Didn't seem to effect computer performance negatively, but I am not constantly waiting for it to spin up now

Can you please explain a little bit more? what's a swap file and how exactly do I do that?

Thanks :D

powerover
05-08-2012, 01:13 PM
Have you tried this:

Control Panel -> Power Options -> Change Advance power settings -> Hard disk -> Turn Off hard disk after _____


Edit: just ignore the above. - since you have done that!

I never have that problem when I had my desktop...I use a seagate green drive in my desk top too and I always set the drives to never turn off...

stupid lappy... :badpc:

McRuff
05-08-2012, 02:06 PM
Can you please explain a little bit more? what's a swap file and how exactly do I do that?

Thanks :D
Swap file is also called a page file or virtual memory and is used by Windows to supplement your RAM.

If you don't have enough RAM your computer will always be swapping data back and forward to Virtual Memory on your hard disk and slow the whole system down. Windows needs virtual memory even if you have plenty of RAM. The advice is normally to put your page file onto the SSD because it is faster. I have one on mine but also put one on the Disk that holds my Data files because it was spinning down and the first time I opened a document in a while I would have to wait for the Disk to spin up. Sort of ruined the whole point of having a SSD to increase performance.

If you right click on Computer Icon, choose properties. Then on the left column click on advance system settings. On the advanced tab click on Performance settings. Under Performance Options go to the advanced tab. Then click on change under Virtual Memory. Deselect automatically manage page file. And then you can set a custom page file size for your drives.

powerover
05-08-2012, 06:19 PM
Done. Thanks very much for the info.

I set the page file to 250MB initial size and a max of 1000MB, hope that is about right?

Lets see if it improves it, will keep you guys posted. :D

Koenig Tiger
06-08-2012, 07:42 PM
Thanks bk T as that worked a treat and I didn't even know that setting was there.I have had this same problem with my green WD....for a while

powerover
06-08-2012, 08:20 PM
McRuff:

it seem to have worked (sort of). I can still hear the drive spinning up, but now it does that every 30 or so (by itself), then it spins down again.
I think I might have set the page file size wrong...or is there some other solution available?

Thanks for the help :D

McRuff
06-08-2012, 08:47 PM
Seems more like a drive issue rather than a windows issue. Have you tried the manufacturers web site for any firmware updates

McRuff
06-08-2012, 09:04 PM
I think I might have set the page file size wrong.
Thanks for the help :D

Windows under Virtual Memory settings will normally recommend a total page file size and I would stick to that. I normally make it a fixed size so the minimum and maximum size is the same as that is supposed to improve performance. On my computer I broke that total amount of virtual memory into two and put most on my SSD C drive and about a third on my Data Drive.

powerover
06-08-2012, 10:04 PM
Seems more like a drive issue rather than a windows issue. Have you tried the manufacturers web site for any firmware updates

there are BIOS updates, but in the updates they didn't mention fixing any bug with regards to my issue..not that I can see anyway, I will double check.


Windows under Virtual Memory settings will normally recommend a total page file size and I would stick to that. I normally make it a fixed size so the minimum and maximum size is the same as that is supposed to improve performance. On my computer I broke that total amount of virtual memory into two and put most on my SSD C drive and about a third on my Data Drive.

will give that a try, will keep you posted. Thanks very much :D