PDA

View Full Version : 64 bit Virtual Box issues.



johnd
06-07-2012, 11:02 AM
Hi

I am needing to run 64 bit virtual machines and am having no luck.

My details are:

Motherboard = D946GZIS
CPU = Intel E5400@2.7GHz x2
OS = Ubuntu 12.04 64 bit.
Virtual Box version = 4.1.12-Ubuntu r77245

The message says that VT-x is not enabled.

I have:

Turned on virtualization in the BIOS.
Upgraded to the latest Ubuntu version of Virtual Box.
Upgraded the BIOS to the latest version. http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=14847&ProdId=2482&lang=eng

I really need to get this working so I don't have to go back to work in the evenings!

Any ideas appreciated.

Thanks
John

ronyville
06-07-2012, 11:12 AM
Under the VM settings for that particular VM, i think you need to enable IO APIC option to run a 64bit guest in a 32bit host. Should be under settings -> system-> just needs a tick.

johnd
06-07-2012, 11:26 AM
Thanks - but not the issue. Doesn't run whether IO APIC is on or off and mine is a 64 bit host anyway.

inphinity
06-07-2012, 12:02 PM
Not all E5400s support the full VT-x instruction set. What is the SPEC code for your specific processor?

johnd
06-07-2012, 02:56 PM
Says on the box S-spec SLGTK

Speedy Gonzales
06-07-2012, 03:26 PM
You sure the CPU supports VT? Since according to Intel it doesnt say it does. (http://ark.intel.com/products/40478/Intel-Pentium-Processor-E5400-%282M-Cache-2_70-GHz-800-MHz-FSB%29#specs)

All it says is see spec details. Which I take it is this

Intel® Virtualization Technology requires a computer system with a processor, chipset, BIOS, virtual machine monitor (VMM) and for some uses, certain platform software, enabled for it. Functionality, performance or other benefit will vary depending on hardware and software configurations. Intel Virtualization Technology-enabled VMM applications are currently in development.

Maybe it doesnt work in Ubuntu? Have you tried it in Windows to see if it'll work (If you use it)?

inphinity
06-07-2012, 03:45 PM
Hmm, that should be ok, SLGT* SPECs were usually the VT-capable ones. Try 'cat /proc/cpuinfo' and look for the 'flags:' line and see if you see either VT-x, svm, or vmx listed.

Have you got the latest BIOS for your motherboard? I'm starting to think the board may not support it.

johnd
06-07-2012, 05:32 PM
The flags are:
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni monitor tm2 ssse3 lahf_lm dts

BIOS has been flashed thgis morning with the latest firmware.

It is not looking good. I have priced a new motherboard, CPU and RAM. I think it is the CPU that is the issue (unfortunately purchased within the last year).

johnd
06-07-2012, 05:34 PM
Maybe it doesnt work in Ubuntu? Have you tried it in Windows to see if it'll work (If you use it)?
I don't have MS Windows on my machine to try it unfortunately.

johnd
06-07-2012, 10:02 PM
Have pretty much decided that the problem is the Intel E5400@2.7GHz x2 CPU not being capable of 64 bit virtualization. Resigned to the fact I will have to purchase a new MB/CPU/RAM combination.

Thanks for your responses.

Chilling_Silence
06-07-2012, 10:16 PM
Have pretty much decided that the problem is the Intel E5400@2.7GHz x2 CPU not being capable of 64 bit virtualization.

Pretty much ... Unfortunately :-/

johnd
09-07-2012, 08:07 PM
Installed a new MB/CPU/RAM combo and all is now going. I wish I had known this before purchasing my dual core Intel to replace the Celeron!