PDA

View Full Version : The Apple guys are going to laugh at this one... shared folders



Agent_24
02-07-2012, 09:19 PM
How does one enable file\folder sharing between Windows and OSX?


I've got a Mac running OSX 10.5 and I want to create a shared folder I can have read\write access to from a Windows machine, I've turned on file sharing and enabled SMB but I can't access anything.

OSX tells me that "Windows users can access your computer at smb://Unknown-<Ethernet's MAC Address here>.lan."


Any hints? I'm sure It's just me doing something stupid.

Speedy Gonzales
02-07-2012, 09:58 PM
This ? (http://www.howtogeek.com/howto/24950/how-to-share-a-folder-in-os-x-with-windows/)

Agent_24
02-07-2012, 10:38 PM
That's pretty much what I did. But it doesn't seem to have worked

icow
02-07-2012, 10:40 PM
Under networking iirc theres a homegroup or workgroup name option (think its workgroup), make sure the mac is in the same workgroup. I did this a while back i dont recall needing the .lan at the end of the server address though, could be a mac only thing?

plod
02-07-2012, 10:40 PM
http://www.ifelix.co.uk/tech/
Easier then explaining
http://www.ifelix.co.uk/tech/3022.html

plod
02-07-2012, 10:46 PM
And why would we laugh?

Agent_24
02-07-2012, 11:06 PM
Under networking iirc theres a homegroup or workgroup name option (think its workgroup), make sure the mac is in the same workgroup. I did this a while back i dont recall needing the .lan at the end of the server address though, could be a mac only thing?

Can't find anything to do with workgroups.

the .lan thing is thanks to my Thomson Speedtouch router and its idiotic firmware.


http://www.ifelix.co.uk/tech/
Easier then explaining
http://www.ifelix.co.uk/tech/3022.html

That seems to be the same thing as what Speedy posted, which I tried, and which didn't work.


And why would we laugh?

Because I have no idea what I'm doing :lol:


The Mac shows up in Windows networking as "MAC00001234567" style name, but if I try to open it, I just get a "The network path was not found."

icow
02-07-2012, 11:12 PM
http://img141.imageshack.us/img141/821/screenshot01y.jpg

Network>properties of the adapter you're using to connect to the network

fred_fish
02-07-2012, 11:13 PM
Have you tried just using the ip address?

icow
02-07-2012, 11:14 PM
Unix systems dont like that. Hence linux and mac needing samba.

CYaBro
02-07-2012, 11:19 PM
Since we're asking stupid questions about MACs :D

How do you create a shortcut on the desktop, in OSX, to a share that's on a Windows PC or a NAS device?

Agent_24
02-07-2012, 11:21 PM
http://img141.imageshack.us/img141/821/screenshot01y.jpg

Network>properties of the adapter you're using to connect to the network

Doesn't seem to have helped :(


Have you tried just using the ip address?


Windows cannot access \\192.168.0.4

Error code: 0x80004005
Unspecified error

Agent_24
02-07-2012, 11:50 PM
Turns out the OSX inbuilt firewall was blocking the connection. Everything is working now... :blush:

Thanks for the help!

fred_fish
02-07-2012, 11:54 PM
One would think a refused connection could be described better than "Unspecified Error" :groan:

The Error Guy
03-07-2012, 12:23 AM
On the windows end it probably didn't know what was going on, the remote machine was broadcasting ARP but when windows tried to handshake nothing happened. A connection refused is different (I think) Firewalls dump any info that doesn't fit the rules so nothing is sent back, whereas a connection refusal means the remote machine sends back a response

fred_fish
03-07-2012, 01:30 AM
Same goes for "No Response from target".

Also, firewalls don't have to drop packets, a reject is equally effective.
With the amount of network traffic generated by today's machines "pretending you are not there" is a bit silly. :)

plod
03-07-2012, 07:38 AM
Turns out the OSX inbuilt firewall was blocking the connection. Everything is working now... :blush:

Thanks for the help!So if you had read my link the first thing it mentions is the firewalls:badpc: Now I will laugh, it seems window users dont follow instructions:lol:

wainuitech
03-07-2012, 09:05 AM
So if you had read my link the first thing it mentions is the firewalls:badpc: Now I will laugh, it seems window users dont follow instructions:lol: looked at the link and its quite good.

But I disagree with the part that says "Both computers may need to have their firewalls turned off " I never turn off the firewall on windows or MAC's, and theres never a problem, and the reason being if you are using a software firewall, and its set to allow the complete IP address of the router through theres nothing to stop it. Most people dont set their firewalls to allow traffic from within the LAN and end up having problems.

Setting the LAN as as described still blocks attacks from outside on the WAN.

Agent_24
03-07-2012, 09:31 AM
So if you had read my link the first thing it mentions is the firewalls:badpc: Now I will laugh, it seems window users dont follow instructions:lol:

Seeing as I had not installed a firewall myself I skipped over that, should have realised it would come with one, but didn't really think about it!

There was no obvious "Firewall" in System Preferences either, just "Security" - Not that I am blaming OSX, but it wasn't obvious to me.

mikebartnz
03-07-2012, 10:16 AM
Because I have no idea what I'm doing :lol:
We have all been there.:confused:

wainuitech
03-07-2012, 10:28 AM
The general exceptions to firewalls, is sometimes if the program plays up its firewall will still block everything even though its all set to allow. The main ones are Norton Internet Security, Trend micro Internet Security. I dont know how many times I've removed them due to corruption of the program and things start working again as they should.

plod
03-07-2012, 07:36 PM
looked at the link and its quite good.

But I disagree with the part that says "Both computers may need to have their firewalls turned off " I never turn off the firewall on windows or MAC's, and theres never a problem, and the reason being if you are using a software firewall, and its set to allow the complete IP address of the router through theres nothing to stop it. Most people dont set their firewalls to allow traffic from within the LAN and end up having problems.

Setting the LAN as as described still blocks attacks from outside on the WAN.To be fair wainui, I have done this so many times and the firewall in OSX has never been a problem with me. Its usually on the windows side.And as it says "may need". But anyway problem solved. I found that site years ago, and keep going back, it seems to have the clearest instructions if you follow them.

plod
03-07-2012, 07:39 PM
Seeing as I had not installed a firewall myself I skipped over that, should have realised it would come with one, but didn't really think about it!

There was no obvious "Firewall" in System Preferences either, just "Security" - Not that I am blaming OSX, but it wasn't obvious to me. I would have thought "Security" would have been an obvious spot for firewall settings. I guess OSX is designed for the more simple people like myself

wainuitech
03-07-2012, 07:41 PM
To be fair wainui, I have done this so many times and the firewall in OSX has never been a problem with me. Its usually on the windows side.And as it says "may need". But anyway problem solved. I found that site years ago, and keep going back, it seems to have the clearest instructions if you follow them.Yep, thats why I said Quite good :thumbs: Didn't have a in depth look, but have it bookmarked now, just in case one day its required.

About the firewalls, generally I find its not any inbuilt windows firewalls, its the third party ones that can cause problems.

Agent_24
03-07-2012, 08:00 PM
I would have thought "Security" would have been an obvious spot for firewall settings. I guess OSX is designed for the more simple people like myself

It does make sense when you think about it, but firewalls were not on my mind. Last time I checked, when you enable file sharing in Windows, it automatically sets the firewall up accordingly anyway.