PDA

View Full Version : Win 7 mapped drive slow



berryb
27-06-2012, 09:20 PM
Installed new Win 7 box on a peer to peer network. Business software runs from XP "server" and all clients have mapped drive and load softwaredirectly from server. Loading business software on Win 7 is very slow taking 15 - 20 seconds to open where XP and Vista takes 1-2 seconds.

When opening the mapped drive Win 7 seems to scan or index the drive with the blue circle rotating. I have disabled the AV. This scan or index does not happen on other mapped drives. I am thinking as the business software is open by other clients it checking the drive.

I also see this on my own pc when opening some drives and the green bar moves across the address bar as though it is scanning.

Ideas on what this actually is and how to turn it off?

I have disabled caching on the shared folder.

1101
28-06-2012, 09:32 AM
Try turning off the indexing service.
This is something that MS really stuffed up. I see many Win7 PC that seem to want to index when not neded, even when you open control panel it 'needs' to be indexed first. Put a CDRom in with lots of files & subdirectories... forget it. Come back in 5 minutes

Also try turning off AV scanning of network drives
- turn off , or on, Network discovery & see if that helps
make sure that Win7 'homegroup' is disabled, & that 7 has the same workgroup name as the other PC's

Whats the spec of the Win7 PC, RAM & CPU speed.?? Connected via wifi or network cable ??
What AV has it got. Try uninstalling AV temporarily & see if that helps, especially if its some sort of 'security suite'

inphinity
28-06-2012, 10:04 AM
Try disabling autotuning for TCP, and also try disabling remote differential compression. Windows 7 is kind of designed under the assumption your file server is not a decade-old OS, so you have to fiddle a bit to get it to perform fully with old stuff ;) Works brilliantly with a 2k8 server though.

SolMiester
28-06-2012, 12:46 PM
I had terrible issues with this and 2008 R2, as SMB 2.0 didnt play very well with my routers....is this the only W7 PC you have issues with?, you could check firmware on your switches...After flashing, mine was sorted, but yeah, if your server is 2003, it is running SMB 1, you could try the above fixes and also registry hack to enforce SMB1 on the W7 PC...

berryb
03-07-2012, 03:21 PM
Thanks for the posts. Have disabeld Search but no effect. Will try the other options and report back.

Paul.Cov
03-07-2012, 04:29 PM
From the Win7 machine, in Explorer, click on the mapped XP drive.

Then click on View

Then Customise this folder (or select the folders properties, and then the Customise tab)

Select Optimize this folder for... General Items, and ensure the tick box for sub folders is also selected.

Hopefully this is your solution.

It is a cure of kinds to the cursed indexing and thumbnailing that MS has forced on us.

berryb
24-07-2012, 02:28 PM
Thanks for the replies but still no luck. Have tried all the above except the reg hack to force SMB1. Can't find the "how to" on Google - prob haven't looked hard enough but I still think it is some kind of indexing as when opening the mapped drive or unc path the green bar scrolls across the top. There are 1500 files in the folder and you can see the file number increase 400, 800 1400 1500. There is no issue with any other network folder but no others have this many files.

And no I cannot remove files!

I turned off indexing (Windows Search) via "turn windows feature on or off".

SolMiester
24-07-2012, 03:13 PM
Hi, not sure indexing works on network drives, however the SMB1 hack is below...
http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm

Is this the only W7 PC?, how old are your switches?

berryb
26-07-2012, 09:50 AM
Thanks Sol will try the hack later today. There are 2 Win 7 PC's with the rest XP. One of the Win 7 is older and doesn't have SP1 installed and doesn't have the issue. The other Win 7 PC (new with SP1) is the problem machine. By memory the switch is an older D-Link 100Mb non managed. I have a spare Gig switch so will try that.

Speedy Gonzales
26-07-2012, 10:04 AM
Try this, the last post (http://social.technet.microsoft.com/Forums/en-ZW/w7itpronetworking/thread/25fd4984-5bdb-42e3-a2aa-47dd46da6326)

Or this (http://www.sevenforums.com/network-sharing/178789-slow-network-drives-after-sp1-install.html)

Update the LAN drivers. Similar to above. The green bar (if you mean when you open a folder on your own computer is slow). I've seen the same thing here. Do what Paul Cov posted. Except change it to Documents. I did this on a whole partition (D). Not just one folder on D

berryb
26-07-2012, 08:16 PM
Well I have tried everything posted and still have the same issue. The other Win7 machine is accessing the same files via wireless so shouldn't be a switch issue unless the port is faulty. I will change the switch to test as it could be a bottleneck as it is only 100mb while the NIC's are Gb. But with wireless in use and OK I don't see it as a speed issue.

berryb
30-07-2012, 04:00 PM
No more posts so will now see what the diff is between non SP1 and SP1.

berryb
13-10-2012, 01:07 AM
Even though this is an older post I like to report back on the result.

This turned out to be the switch. I put in a gigabit switch and issue solved.