PDA

View Full Version : New Linux install multi-boot problem



Tony
17-05-2012, 02:50 PM
I've just installed PCLinuxOS, which looks great. My only problem (so far :)) is getting it to play nice and multi-boot with the other OSs on the machine.
I should say, and I recognise that this may well be what is complicating matters, that I have 4 physical disks, 3 SATA each with several partitions, and 1 IDE. I have Win7 and Win8 on one SATA disk, and Vista on another SATA disk. The IDE has 3 partitions, 2 Linux and one Linux swap.

When I installed it said it had installed GRUB. When I boot, I get my "normal" options, but there is no Linux option. If I change the boot order in BIOS to make the Linux disk first, I get what I assume is the GRUB text menu. This will boot PCLinuxOS, but if I try the single "Windows" option, it peters out saying it can't find the correct files.

I've used EasyBCD under Win7 to try to load an entry for Linux, but whichever partition on the "Linux disk" I point it at, it won't work when I boot. If I select that option, I just get a blank screen with a blinking cursor.

Any ideas?

KarameaDave
17-05-2012, 03:36 PM
Yes,

Does your motherboard's BIOS have a quick boot selection option?
Mine is to press esc on the laptop, then a small BIOS menu comes up
and I select my USB flash drive.
That way you could just boot straight to the Linux drive when you want to
without worrying about configuring GRUB or the BCD

Then later if you decide not to keep the Linux installation
you won't have wasted any effort.

Agent_24
17-05-2012, 03:54 PM
It's odd, it should just work, actually.

The fact that Ubuntu couldn't correctly identify your Windows installations and that your current GRUB install can't load the Windows entry (and in fact, doesn't list all of your Windows installations separately) leads me to believe there is something funny with the way your Windows bootloaders may be set up.

Tony
17-05-2012, 03:56 PM
Yes,

Does your motherboard's BIOS have a quick boot selection option?
Mine is to press esc on the laptop, then a small BIOS menu comes up
and I select my USB flash drive.
That way you could just boot straight to the Linux drive when you want to
without worrying about configuring GRUB or the BCD

Then later if you decide not to keep the Linux installation
you won't have wasted any effort.I know what you mean. Yes on the laptop, no on the multi-boot PC.

Tony
17-05-2012, 03:57 PM
That's really comforting :(. Anything I can do about fixing the windows bootloader?

Agent_24
17-05-2012, 04:07 PM
That's really comforting :(. Anything I can do about fixing the windows bootloader?

I'm not really sure because I've never had that problem...

I've got XP and Windows 7 installed on two physically separate drives with their own bootloaders per each drive. GRUB lists both and can boot both.

Maybe you've got just one copy of the bootloader that runs all 3 of your Windows installations? Which Windows drive is the BIOS set to boot from? What happens if you tell it to boot from the other?


Try running the terminal in Linux, and running 'update-grub' and post here what it outputs.

Tony
17-05-2012, 04:14 PM
OK, I'll try that. In the meantime, here is what EasyBCD says about my configuration:

3805

Tony
17-05-2012, 04:23 PM
This is what happened:

[tony@localhost ~]$ update-grub
bash: update-grub: command not found
[tony@localhost ~]$

BTW, note I am posting this from FF under Linux. :)

Agent_24
17-05-2012, 04:37 PM
Perhaps try 'update-grub2' instead

Note, while typing commands in Linux, you should be able to press Tab halfway through to auto-complete the command or show various options.


Then again, it might only work in Ubuntu...

Tony
17-05-2012, 04:41 PM
Same response. If I hit Tab it doesn't give me that as an alternative:

[tony@localhost ~]$ upda
update-alternatives update-localtime
updatedb update-menus
update-desktop-database update-mime-database
update-ldetect-lst update-usbids.sh
[tony@localhost ~]$

Rod J
17-05-2012, 04:50 PM
Try sudo update-grub

You need to be admin/root user to do that

Tony
17-05-2012, 05:02 PM
Doesn't recognize sudo either. I seem to remember something on the PCLinuxOS website that talked about "why we hate sudo". Didn't take any notice at the time.

Rod J
17-05-2012, 05:04 PM
Actually the above might not work. I see PCLinuxOS uses Grub legacy not Grub2 as used in Ubuntu, etc.

This might help: http://pclosmag.com/html/Issues/201101/page10.html

KarameaDave
17-05-2012, 06:07 PM
Tony,
I notice in your BCD config that the Linux drive is listed as C drive
as well as one of the Windows instances.
Perhaps that may be part of it.

mikebartnz
17-05-2012, 06:32 PM
This is what happened:

[tony@localhost ~]$ update-grub
bash: update-grub: command not found
[tony@localhost ~]$

BTW, note I am posting this from FF under Linux. :)
I know nothing about EasyBCD. When in PCLinuxOS look in /boot/grub and open menu.lst and show us what you have there and list where every Windows version is installed and booting from.
If you click on the open ender spanner +screw driver icon (Configure your computer) then goto Boot/Set up boot system you can redo grub from there.

johnd
17-05-2012, 11:03 PM
I've used EasyBCD under Win7 to try to load an entry for Linux, but whichever partition on the "Linux disk" I point it at, it won't work when I boot. If I select that option, I just get a blank screen with a blinking cursor.
I think that is because both GRUB legacy and GRUB2 have two parts to the boot loader - under a normal installation part 1 is on the mbr and part 2 in the Linux partition. For EasyBCD to chain load to Linux, both parts have to be on the Linux partition. This option should be given during the Linux install - or I think you can use grub-install /dev/sdxx (e.g. sdb3 or what ever your situation is). As with any instructions like this, it pays to do your own research before you begin - boot loader stuff can be nasty!

mikebartnz
17-05-2012, 11:10 PM
Doesn't recognize sudo either.
Just use the root terminal.

Tony
18-05-2012, 11:31 AM
OK, after a bit of messing around I have a partial solution - though not ideal. When I boot, I get the Grub menu. One of the items is "windows". If I select that I then get my old multi-boot menu to select Win7, Win8 or Vista. What I would prefer is the reverse situation - the original menu first up, with a "linux" option, but I can't seem to get that to work.

The above scenario worked after I deciphered the Linux disk designations (SDxxx) and mapped them to the Windows/Bios definitions of which disk is which, and which disk was my windows boot disk, and reconfigured Grub accordingly. It was made harder by the fact that two of my disks are identical hardware, and so both show up just as "ST3250620AS", without further differentiation.

OT, but still PCLinuxOS, how do I change the desktop background from the PCLinuxOS sort of gunmetal effect to a plain colour? I've been into "configure desktop", but can't see anything there.

mikebartnz
18-05-2012, 11:40 AM
OT, but still PCLinuxOS, how do I change the desktop background from the PCLinuxOS sort of gunmetal effect to a plain colour? I've been into "configure desktop", but can't see anything there.
Right click on the desktop and choose desktop settings. You may have to create a wallpaper to get what you want. I find having a different wallpaper on each desktop can make life easier.

Tony
18-05-2012, 11:49 AM
So I can't just do the Windows thing and choose a colour?

mikebartnz
18-05-2012, 12:02 PM
So I can't just do the Windows thing and choose a colour?
Yes you can just change the Wallpaper from Image to colour.