PDA

View Full Version : D-Link DWL-G122 wireless adapter trouble



ChazTheGeek
24-04-2012, 02:49 PM
Hi, I can't seem to get a wireless adapter going, I've installed the drivers and nothing happens. There are missing .dll files:groan:. I've downloaded them and tried to get them going, but without success.
Here are the missing .dll files, I don't know whether that's all of them: msvcrt.dll, wlanapi.dll
What you people think?

Speedy Gonzales
24-04-2012, 02:51 PM
Did you get the drivers from the Dlink site? What version of windows is it? Same prob / fix is here (http://answers.microsoft.com/en-us/windows/forum/windows_vista-hardware/wlanapidll-missing/38b71a1f-406f-e011-8dfc-68b599b31bf5?msgId=7002bb38-0870-e011-8dfc-68b599b31bf5)

ChazTheGeek
24-04-2012, 02:54 PM
Got it from softpedia.com have tried D-link themselves but that didn't work. I could try again. I am using windows XP Home edition 32 bit SP3.

Speedy Gonzales
24-04-2012, 03:03 PM
This maybe the reason (http://support.microsoft.com/kb/950720). I think that error only appears in XP. Do one of these messages appear on startup too? This may help?


(http://kb.cadzow.com.au:15384/cadzow/details.aspx?ID=1898)

ChazTheGeek
25-04-2012, 11:24 AM
Hi speedy, no I have no messages to do with SP3, Had no trouble with it. The problem is the D-Link...

Speedy Gonzales
25-04-2012, 11:35 AM
Are you using the Dlink airplus util?? If you are, dont. Use windows for the wireless

ChazTheGeek
25-04-2012, 12:48 PM
I can't even get the utility going, heaps of missing .dll files. I try the windows option in win XP.

Speedy Gonzales
25-04-2012, 01:25 PM
Uninstall the util (keep the driver). Then use Windows for it

ChazTheGeek
25-04-2012, 02:22 PM
I'll give it a go.

Speedy Gonzales
25-04-2012, 02:31 PM
If you cant figure it out, get teamviewer. Install it then run it. Send me the ID and password it gives you in a PM