PDA

View Full Version : Web page display in IE



JonB
13-03-2012, 09:57 PM
Help needed please from an expert.
I have a website "www.seniornetgardencity.co.nz" which displays perfectly in Firefox browser but in Internet Explorer 8, for all pages, it displays the banner header but no more. In IE it activates the "compatibility mode" but clicking that does not fix the problem. Could somebody who knows about these things cast an eye over the source code and suggest what may be wrong or what I am missing? Thanks in anticipation. JonB

mzee
14-03-2012, 05:23 PM
Doesn't display with IE9 either!
Try this:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

Required if page has xhtml in it.

mzee
14-03-2012, 05:42 PM
Doesn't display with IE9 either!
Try this:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

Required if page has xhtml in it.

Not the answer! This does it:
<meta http-equiv="X-UA-Compatible" content="IE=8" />

Place it above the Title.

kahawai chaser
14-03-2012, 05:43 PM
Test for compliance, i.e. xhtml markup at W3. (http://validator.w3.org/)

pctek
14-03-2012, 05:44 PM
I can see it in IE. Blue and yellow menu down the left. Green writing in the middle.
And so on.
This is IE version 8.

mzee
14-03-2012, 05:49 PM
Maybe it will not display if 'Active x' is turned off?

My IE9 will only display it if <meta http-equiv="X-UA-Compatible" content="IE=8" /> is in the file.

Speedy Gonzales
14-03-2012, 06:26 PM
Works fine in IE9 and FF 11.

mzee
14-03-2012, 06:44 PM
Works fine in IE9 and FF 11.

Works in FF and Chrome as is, but My IE9 will only display it with <meta http-equiv="X-UA-Compatible" content="IE=8" /> in it! Probably would if I had the latest updates. Don't use IE anyway.

lakewoodlady
14-03-2012, 07:12 PM
Works ok in Android browser . IE is always a pain whatever version. Will check on Vista machine using IE 9.

LL

lakewoodlady
14-03-2012, 07:17 PM
ok, IE 9 on vista works fine, also Chrome and Firefox works fine too.

LL

ps, check my sig for seniornet taupo.

nerd89
14-03-2012, 08:45 PM
Works on IE9 ok. W7 (not that I'd ever willingly use IE)

JonB
15-03-2012, 12:51 PM
Thanks to all for your replies, much appreciated. Added the correct Doctype etc. and all is now good. Internet Explorer is extremely "picky" compared with most other browsers but sure keeps you on your toes. Most SeniorNet users however are using IE by default and so it has to work for them! Again, thanks for your input.
JonB