PDA

View Full Version : Apache won't start anymore



Mike
14-12-2011, 07:15 PM
I've had Apache running on my PC for the past couple of years (or more). Today we had a power outage - I got the wife to shut down the computer beforehand. After power came back on we turned the computer on again but Apache won't start now - I've restarted 3 times now but still refuses to start. The PC was last restarted on Sunday or Monday and Apache started fine then. Nothing has been installed recently (that I know of...)

I get an error when trying to start:
---------------------------
Services
---------------------------
Windows could not start the Apache2.2 on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 1.
---------------------------
OK
---------------------------

I tried a httpd -k start which gave an error "an attempt was made to access a socket in a way forbidden by its access permissions apache". It seems something is blocking ports 80 and 443. Thought it might be skype, but having skype not running makes no difference (skype doesn't auto start anyway). Found a thread online saying possibly SSRS or SSIS, but I'm not running either of those services. I stopped all other SQL Server services which didn't help.

Any suggestions on what it might be causing this and how to fix it?

Thanks,
Mike.

Mike
14-12-2011, 07:19 PM
The Windows Event log gives the following errors when I try to manually start Apache:

The Apache service named reported the following error:
>>> (OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80 .

The Apache service named reported the following error:
>>> (OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80 .

The Apache service named reported the following error:
>>> no listening sockets available, shutting down .

The Apache service named reported the following error:
>>> Unable to open logs .


Cheers,
Mike.

fred_fish
14-12-2011, 10:53 PM
The Windows Event log gives the following errors when I try to manually start Apache:

The Apache service named reported the following error:
>>> (OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80 .

The Apache service named reported the following error:
>>> (OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80 .
Windows (or other) firewall blocking those ports (or by process)?

The Apache service named reported the following error:
>>> no listening sockets available, shutting down .
Apache is not dieing but shutting down gracefully, pointing to a problem elsewhere.

The Apache service named reported the following error:
>>> Unable to open logs .
That doesn't sound good. Where is the apache log?

Mike
15-12-2011, 07:52 PM
Terminating on signal SIGTERM(15)
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
That's what the Apache log files say. It appears its happily writing to the log files it can't open...? :)

I don't know what's blocking those ports :D I'll try the firewall... Although seems odd that it just started to happen after working happily for a long time.

Cheers,
Mike.

ColdCold
19-12-2011, 11:54 AM
hey Mike, yeah, I've been hitting my head against the wall all day with this one, trying all sorts of things, reading dozens of articles and posts, nothing worked for me... until...
I disabled the "Web Deployment Agent Service". Now Apache is happy as a clam. (Are clams really so happy? maybe... but I digress). :)
Hope this helps you out. After figuring it out I found more info here: http://forums.iis.net/p/1180922/1993110.aspx

-ColdCold

Chilling_Silence
19-12-2011, 12:07 PM
It means theres another program already running on Port 80. Find out what that is and close it, or get apache to run on something else like 8080 for example :)

Mike
27-12-2011, 10:48 AM
Well, no idea what happened, but it just started working again after a few days... maybe a windows update? I don't know...

Thanks for the suggestions anyway though :)

Mike.