PDA

View Full Version : Cisco 857 ADSL Config



WarNox
21-11-2011, 09:48 PM
Hey,

I want to configure a Cisco 857 for ADSL. Below is a working config but I've got no idea which parts are required. Comparing it to the below link from Cisco most commands do not match up. If someone could let me know which parts are required that would be great. I don't want to install something that works if I've got no idea why :) Too bad CCNA doesn't teach you this stuff.

Cisco's way:
http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/pppoanat.html#wp1230011

Working config:

!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 0/100
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 10.0.0.254 255.255.255.0
ip access-group 102 in
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Dialer0
ip address negotiated
ip access-group 101 in
no ip redirects
no ip unreachables
ip inspect firewall out
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp pap sent-username xxxxx password 7 xxxxx
ppp ipcp dns request
ppp ipcp route default
!
ip forward-protocol nd
!
...
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static 10.0.0.1 interface Dialer0
!

Thanks for any help.

stormdragon
22-11-2011, 07:14 PM
Would help if we knew exactly what you were trying to achieve!

WarNox
22-11-2011, 09:49 PM
Hmm yea, I did not word that right at all.

Lets start again. If I wanted to learn to configure one of these things for ADSL in NZ, where would I start?