PDA

View Full Version : PC wont detect OS partition



GeneralKanos
29-10-2011, 12:38 PM
Hello all, long time no see!

I have built a small file server at home but with the shortage of HDD's at the moment I have decided to install Server 2008 on a small partition at the end of one of my data disks.

Due to complications getting the OS to install while the HDD was in the FileServer, I decided to install the OS using my workstation.
While the HDD was plugged into my workstation I created an 80GB partition at the end of the HDD and installed Server 2008.
I then removed the HDD from my workstation and placed it in the FileServer.
I booted the FileServer and checked the BIOS to make sure the HDD appeared - it did and everything looks good.
The FileServer will not, however, detect the Server OS.

I am certain this is because it was installed while in another PC and so the boot manager is confused.

I have 2 options that I see:

1. Try to get the OS installed while the HDD is in the FileServer
2. Try to modify the bootmgr to get the FileServer to detect the Server OS

The HDD is a 1.5TB Seagate and the mobo of the FileServer is an P8Z68-M Pro

FYI - the issue with the Server OS not being able to be installed via the File Server is that when I go to select the drive to install it to it gives an error saying "required CD/DVD drive device driver missing".
Does this mean that I need to find a driver for the HDD? There is no DC/DVD drive in the FileServer at all.


TIA,
GK

Speedy Gonzales
29-10-2011, 01:35 PM
If server 2008 was an ISO, it maybe corrupt (http://social.technet.microsoft.com/Forums/en-US/winserversetup/thread/44b25f00-739a-4387-a24e-c0795e3bda65/). Or try this. (http://social.technet.microsoft.com/Forums/en-US/winserversetup/thread/249463b0-f940-4f7d-a3c3-130e34938a97/). Or if its SATA and AHCI is enabled in the BIOS, it may need SATA drivers (if server 2008 doesnt have any)

GeneralKanos
29-10-2011, 03:36 PM
Cool, I burned the ISO to a DVD and ripped the DVD drive out of my workstation.
I am now selecting which drive to install the OS to and I get a new error:
"Windows cannot be installed on this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only be installed to GPT disks."

If I chuck the HDD back into my workstation can I edit the partition table to be GPT from MBR?

Speedy Gonzales
29-10-2011, 03:56 PM
Is it server 2008 x86 or x64?? Looks like x64 can give you probs

GeneralKanos
29-10-2011, 04:10 PM
Yea its x64.
Looking online its simple enough to do, I just need to find somewhere to backup 1TB of data :(

GeneralKanos
29-10-2011, 10:16 PM
Lastly, I backed up and wiped the drive, converted it to GPT and started to install the OS and now its saying: "The partitions on the disk selected for installation are not in the recommended order. For information about installing to GPT disks go to the Microsoft website (www.microsoft.com) and search for GPT."

I can see a 128MB MSR (Reserved), 100MB System reserved, the 80GB partition and the rest unallocated.

The MSR partition was there when I booted and the 100MB was created when I created the 80GB partition inside the "Install Windows" menu.

Safe? Unsafe? Doesn't matter?

Cheers,
GK

Silvester696
30-10-2011, 01:06 AM
Lastly, I backed up and wiped the drive, converted it to GPT and started to install the OS and now its saying: "The partitions on the disk selected for installation are not in the recommended order. For information about installing to GPT disks go to the Microsoft website (www.microsoft.com) and search for GPT."

I can see a 128MB MSR (Reserved), 100MB System reserved,Duplicate File Cleaner the 80GB partition and the rest unallocated.

The MSR partition was there when I booted and the 100MB was created when I created the 80GB partition inside the "Install Windows" menu.

Safe? Unsafe? Doesn't matter?

Cheers,
GK
improve computer performance & hard disk reliability organize files, find duplicate files, and disk space guide about how to improve hard files with duplicate entries and remove them and economize the disk space for.