PDA

View Full Version : OpenSUSE not booting



benZ
10-10-2011, 09:05 PM
My OpenSUSE stopped booting for a while (it's fine now). The failsafe boot option didn't work

What do people do in this situation? (for OpenSUSE or other distros)

I'm a bit of a newb with linux

Jen
10-10-2011, 09:37 PM
Did it fix itself?

Normally you would look for the error message and ask (or search) for what may have cause it and a solution.

johnd
10-10-2011, 10:20 PM
What you would do depends on whether the error is a boot loader problem or after that - i.e. an OS loading problem. Typically you might try to re-install the boot loader or fsck (file system check) the boot partition. However if this happens it normally indicates something quite serious is wrong!

benZ
10-10-2011, 10:32 PM
Yes it fixed itself

I was interested in knowing what sort of things people did when linux doesn't boot - such as boot disks under Windows

Looking up the error message is a good suggestion. I assume tho that not all boot problems have an easy solution

Just generally interested

:)

benZ
10-10-2011, 10:42 PM
@johnd

yeah I'm wondering now if the hardware is a bit flaky

Is there some standard set of tools to do that stuff? (recovery disk or something)

Thanks for suggestions

johnd
11-10-2011, 07:25 PM
The tools used by most people are either the live CD from the distribution you have installed or better something like PartedMagic. (http://sourceforge.net/projects/partedmagic/)

benZ
11-10-2011, 08:13 PM
Thanks. Ran fsck- seemed to work, am downloading the ISO

Problem comes and goes- i think swap partition getting errors