PDA

View Full Version : disabled autorun



16-10-2001, 02:29 PM
A hard disk crash caused me to reformat and reload windows 98 SE and other software. But autorun does not happen, even though enabled in Device Manager/cdrom/properties/settings. In the registry the key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es/CDRom is absent. Software loads OK from start/run/d:\setup.exe etc. Any suggestions?

16-10-2001, 03:30 PM
Are you /sure/ you don't have your finger on the shift key? :-)

Seriously, Win98SE should have autorun enabled by default. Have you run a 'tweaking' program, that may have deleted the entry?

16-10-2001, 03:42 PM
Go to Control Panel/System/Device Manager, click on your CDROM entry and click properties.
Ensure Auto Insert Notification is enabled for any drives you want Autorun to work on.

16-10-2001, 05:02 PM
Thanks Dylan. No, I haven't run a tweaking programme since I reformatted the hard disc. However, I did put the system files onto the reformatted disc using a Win 98 startup disc, and then tried loading the programmes it came with (It's a gateway 2150 laptop running at 466MHz)

16-10-2001, 05:29 PM
Thanks Iain

As I said in my first post, I had already gone into Device manager/double clicked on LG CD-ROM CRN-8241B (the cdrom drive) to get properties/settings and ensured 'auto insert notification' was ticked, and the drive was 'D'. I also looked at http://support.microsoft.com/support/kb/articles/Q155/2/17.asp . The other 2 keys mentioned have HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer NoSriveTypeAutoRun = ff 00 00 00 as does the 'HKEY_USERS\\\'. They said to type in Ox0000095, but it does not allow 'x' to be input over the FF. I am stumped!